Enable shift + drag for folders in bookmarks toolbar on Mac

VERIFIED FIXED in Firefox 3.1b1

Status

()

Firefox
Bookmarks & History
P3
normal
VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: Christine Yen, Assigned: mak)

Tracking

({regression, user-doc-complete})

Trunk
Firefox 3.1b1
All
Mac OS X
regression, user-doc-complete
Points:
---
Dependency tree / graph
Bug Flags:
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 418671])

Attachments

(1 obsolete attachment)

(Reporter)

Description

11 years ago
Dragging a folder (normal folder or a livemark) within the bookmarks toolbar to rearrange items doesn't work anymore - possibly a regression of bug 334244?
I see this too in Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/200707270404 Minefield/3.0a7pre.
If we are going by fx2 parity, we shoudln't be able to drag a folder or a livemark within the toolbar, no? Bug 334244 was to fix folder/livemark from dragged around within the toolbar.
Sorry. Part of the fix from 334244 fixed folder/livemark from being dragged around within the toolbar.Fx2 also doesn't drag a folder/livemark within toolbar with just a click+drag.
Dupe of bug 235244? Although this is a Bookmarks bugs, not a Places bug.
(Reporter)

Comment 5

11 years ago
Yes - similar to that... I understand that the fix for bug 334244 was for Fx2 parity, but - hmm. Shift+drag+click doesn't currently work in places either. Changing this bug summary to "Re-enable Shift+click+drag for folders in bookmarks toolbar"
Summary: Can't drag a folder around on the bookmarks toolbar → Re-enable shift + click + drag for folders in bookmarks toolbar
Flags: in-litmus?
How does Shift change things?
(Reporter)

Comment 7

11 years ago
(In reply to comment #6)
> How does Shift change things?
> 

I was looking at some related bugs, like bug 235244, in which someone says that holding down shift shouldn't be required to move folders in the toolbar. this bug is more about the fact that there should be /some/ way to rearrange folders within the toolbar itself...

Updated

11 years ago
Blocks: 323438
(Assignee)

Updated

11 years ago
Duplicate of this bug: 415071

Updated

11 years ago
Duplicate of this bug: 400664

Comment 10

11 years ago
re: blocking-firefox3
This same problem was marked blocking by beltzner on bug 400664, which was just duped to this.
Flags: blocking-firefox3?

Comment 11

11 years ago
^^ Ignore that, please.
Flags: blocking-firefox3?
(Assignee)

Comment 12

11 years ago
Created attachment 303260 [details] [diff] [review]
enable shift|ctrl drag

this should do the trick, pitifully i can only test on Windows and Linux (and i can confirm that on Linux folder drag does not work at all).

I need someone to help testing this patch on Mac.
(Assignee)

Updated

11 years ago
Keywords: qawanted
Is this fixed in another bug?

Comment 14

10 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008050209 Minefield/3.0pre
can't rearrange foldersin this build

Comment on attachment 303260 [details] [diff] [review]
enable shift|ctrl drag

patch looks fine and tested ok on mac.
Attachment #303260 - Flags: review+
Keywords: qawanted
Priority: -- → P3
Whiteboard: [has patch][has review]
Target Milestone: --- → Firefox 3.1
Blocks: 437246

Comment 16

10 years ago
WFM on Windows, patch is Mac-only, so adding "on Mac" to summary.
Summary: Re-enable shift + click + drag for folders in bookmarks toolbar → Re-enable shift + click + drag for folders in bookmarks toolbar on Mac

Comment 17

10 years ago
So is this stuck right now? Just ran into this bug personally today and wanted to check up on the status. :)
(Assignee)

Updated

10 years ago
Depends on: 418671
(Assignee)

Updated

10 years ago
Blocks: 410865
(Assignee)

Comment 18

10 years ago
Comment on attachment 303260 [details] [diff] [review]
enable shift|ctrl drag

fix submitted with patch in bug 418671

Can someone with a Mac check if this is fixed on 20080920033605 nightly build?
Attachment #303260 - Attachment is obsolete: true
(Assignee)

Comment 19

10 years ago
tested fixed on
Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1b1pre) Gecko/20080921021112 Minefield/3.1b1pre
Assignee: nobody → mak77
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Summary: Re-enable shift + click + drag for folders in bookmarks toolbar on Mac → Enable shift + drag for folders in bookmarks toolbar on Mac
Whiteboard: [has patch][has review]
(Assignee)

Updated

10 years ago
Assignee: mak77 → nobody
Target Milestone: Firefox 3.1 → Firefox 3.1b1
(Assignee)

Updated

10 years ago
Assignee: nobody → mak77
Verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20080921021112 Minefield/3.1b1pre ID:20080921021112
Status: RESOLVED → VERIFIED
Hardware: PC → All
Whiteboard: [fixed by bug 418671]
(Assignee)

Updated

10 years ago
Duplicate of this bug: 410865
(Assignee)

Updated

10 years ago
No longer blocks: 410865
user-doc-complete
<http://support.mozilla.com/kb/Organizing+Bookmarks?bl=n#Re_arranging_the_Bookmarks_Toolbar>
Keywords: user-doc-needed → user-doc-complete
Test case 7454 has been created to regression test this bug in the future.

Updated

10 years ago
Flags: in-litmus? → in-litmus+
Sammy, could you please post the link to the test in the future? That would help us a lot.

I have two concerns which should be fixed:

1. Cmd/Ctrl+B isn't used to open the toolbar but the sidebar.
2. You don't mention the shift key for dragging a folder.
Flags: in-litmus+ → in-litmus?
Thanks for the check Henrik, I've made the necessary changes to the test case. Here's the link: https://litmus.mozilla.org/show_test.cgi?id=7454

Updated

10 years ago
Flags: in-litmus? → in-litmus+
Thanks for the quick fix and your patience with me.
(Assignee)

Updated

10 years ago
Duplicate of this bug: 436235
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.