[FIXr]Inserting a caption into a table doesn't work

RESOLVED FIXED in mozilla1.9beta1

Status

()

Core
Layout: Tables
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: bz, Assigned: bz)

Tracking

({fixed1.8.1.8, regression})

Trunk
mozilla1.9beta1
x86
Linux
fixed1.8.1.8, regression
Points:
---
Bug Flags:
blocking1.8.1.8 +
blocking1.8.0.next +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: regression from bug 309322)

Attachments

(1 attachment)

This is a regression from bug 309322.  We're not reflowing the new caption...
Requesting the same blocking flags that bug 309322 has.
Flags: blocking1.8.1.7?
Flags: blocking1.8.0.13?
Created attachment 274251 [details] [diff] [review]
Fix
Attachment #274251 - Flags: superreview?(dbaron)
Attachment #274251 - Flags: review?(bernd_mozilla)
Comment on attachment 274251 [details] [diff] [review]
Fix

sr=dbaron
Attachment #274251 - Flags: superreview?(dbaron) → superreview+

Updated

10 years ago
Attachment #274251 - Flags: review?(bernd_mozilla) → review+
Summary: [FIX]Inserting a caption into a table doesn't work → [FIXr]Inserting a caption into a table doesn't work
Comment on attachment 274251 [details] [diff] [review]
Fix

Make sure to mark a caption being inserted dynamically into a table as needing reflow.  Very safe regression fix.
Attachment #274251 - Flags: approval1.9?
Comment on attachment 274251 [details] [diff] [review]
Fix

a19=dbaron
Attachment #274251 - Flags: approval1.9? → approval1.9+
Fixed.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Flags: blocking1.8.0.13? → blocking1.8.0.14?
Keywords: regression
Flags: blocking1.8.1.7?
Flags: blocking1.8.1.7+
Flags: blocking1.8.0.14?
Flags: blocking1.8.0.14+
Whiteboard: regression from bug 309322
What did we use for PresShell::FrameNeedsReflow() on the 1.8 branch? I don't know how to back-port this one.
Basically, nsTableOuterFrame::InsertFrames needs to do what nsTableOuterFrame::AppendFrames does (on branch, that uses AppendReflowCommand).
thanks, that fixed the regression. I think I'll wrap all these regressions up into a combined 1.8 branch patch for re-review.
branch fix checked in with bug 309322
Keywords: fixed1.8.1.8
Needed on the 1.8.0 branch only if bug 309322 lands.
Flags: blocking1.8.0.14+ → blocking1.8.0.15?
Since 309322 is marked blocking1.8.0.15+ carrying over blocking to this bug too.
Flags: blocking1.8.0.15? → blocking1.8.0.15+
You need to log in before you can comment on or make changes to this bug.