Full page zoom does not affect text with CSS font set to message-box

VERIFIED FIXED

Status

Core Graveyard
GFX
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: Ehsan, Assigned: Eli Friedman)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072812 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072812 Minefield/3.0a7pre

The newly implemented full page zoom in the "about:" page does not affect the size of the text on the page.

Reproducible: Always

Steps to Reproduce:
1. Install the "Full Page Zoom" extension in a recent nightly.
2. Go to the URL of this bug (about:).
3. Select the Zoom In or Zoom Out toolbar buttons.
Actual Results:  
The graphics are scaled up/down, but the text is not.

Expected Results:  
All of the page elements must be scaled.

about:buildconfig

Build platform
target
i686-pc-cygwin

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	14.00.50727 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	14.00.50727 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE) -I/usr/X11R6/include

Configure arguments
--enable-application=browser --enable-application=browser --disable-debug --enable-optimize --enable-canvas --enable-svg --enable-xpctools --enable-places --enable-places-bookmarks --enable-storage --enable-safe-browsing --enable-url-classifier --enable-strip --disable-javaxpcom
I found out that this bug is related to the use of CSS "font: message-box" on text.  I'll be attaching a testcase soon.
Summary: Full page zoom in "about:" does not affect text → Full page zoom does not affect text with CSS font set to message-box
Created attachment 274264 [details]
Testcase

The testcase for this bug
Moving to the Core : GFX component...

Correcting the URL for this bug...

Setting the dep on bug 4821...
Blocks: 4821
Component: General → GFX
Product: Firefox → Core
QA Contact: general → general
Flags: blocking1.9?
(Assignee)

Comment 4

10 years ago
Hmm, I guess we want to use unscaled device pixels for measuring system fonts because users will expect them to scale.

(I might comment, though, that if the user has trouble reading text at this size, they should change their OS settings.)
We don't want high DPI to affect system fonts, though.
(Assignee)

Comment 6

10 years ago
Created attachment 274373 [details] [diff] [review]
Patch
Assignee: nobody → sharparrow1
Status: NEW → ASSIGNED
Attachment #274373 - Flags: review?(roc)
Attachment #274373 - Flags: superreview+
Attachment #274373 - Flags: review?(roc)
Attachment #274373 - Flags: review+
(Assignee)

Comment 7

10 years ago
Comment on attachment 274373 [details] [diff] [review]
Patch

Low-risk patch; should only affect page zoom.
Attachment #274373 - Flags: approval1.9?

Updated

10 years ago
Attachment #274373 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 8

10 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Verified in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007080500 Minefield/3.0a8pre...
Status: RESOLVED → VERIFIED
Clearing the blocking1.9 request...
Flags: blocking1.9?
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.