bookmarks take favicon of previously visited site when target site is unconnectable

RESOLVED DUPLICATE of bug 383453

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 383453
11 years ago
11 years ago

People

(Reporter: hubert hubertson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.5) Gecko/20070713 julian/1.3.3.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.5) Gecko/20070713

following scenario:

page 1 has a favicon. i visit page 1, get to see the favicon in the address-bar, it also shows up in a previously made bookmark of page 1.

then, i disconnect my router from the internet in order to make the following page 2 unaccessible.

page 2 has no favicon, but is also bookmarked. still being on page 1, i navigate to page 2. as there is no internet connection, firefox can't load the page.

when i now look under bookmarks however, page 2 has taken on the favicon of page 1.

this has been reproduceable with every recent build of firefox i have tried; stable and unstable.

Reproducible: Always

Steps to Reproduce:
1. make two bookmarks, one of a page with favicon, one without.
2. visit the one with the favicon, see that the bookmark gets its favicon
3. disconnect your access to the page without favicon
4. visit the page without favicon
Actual Results:  
the bookmark of the page without favicon will take on the favicon of the previously visited page.

Expected Results:  
it doesn't.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383453
You need to log in before you can comment on or make changes to this bug.