Misrendering on Mac on SVG Photos demo

RESOLVED DUPLICATE of bug 379429

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 379429
11 years ago
11 years ago

People

(Reporter: bz, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

Screenshot attached.  The problems in the three photos that are in the middle vertically are:

Leftmost:  Photo not rotated right, image duplicated
Middle: Somehow broken up into 4 pieces
Right: Broken up into two pieces

I suspect it's all the same problem.

Filing on Thebes, but I don't see this on Linux, so this may be down in cairo Mac code or something.
Attachment #274349 - Attachment is patch: false
Attachment #274349 - Attachment mime type: text/plain → image/png
So...attempting to load that attachment as plain text was crashing my current trunk build...

New bug?
Bug 390032 covers the crash on Mac.  I _think_ the crash might be XP, but not sure.

Want to mail me how you managed to change the attachment stuff what with the crash?
Flags: blocking1.9?
Already fixed in new cairo, just needs landing (and getting it to stick).
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 379429
You need to log in before you can comment on or make changes to this bug.