Firefox fails to detect as feed and renders as xml

VERIFIED DUPLICATE of bug 364677

Status

()

Firefox
RSS Discovery and Preview
VERIFIED DUPLICATE of bug 364677
11 years ago
9 years ago

People

(Reporter: mossop, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
This feed (which admittedly isnt perfectly valid but close enough I think) isn't detected by Firefox as a proper feed and displayed in the feedreader. I've confirmed this in Bonecho and Minefield. The page is sent as text/html however somehere along the way Firefox is deciding to display it as if it were xml.

I think it's a failure that it isn't detected as a feed in the first place, though if the feed really is that bad that we can't autodetect from it then fine, but I think it's a worse failure to display it as a mimetype which is neither what it is sent as nor something that we safely parse.
<channel> needs a valid <link> node for firefox to detect it.

> The page is sent as text/html

actually it's sent as text/xml, which explains firefox's behavior.
(Reporter)

Comment 2

11 years ago
Hmm that's kinda weird, the header sniffer I have used and trusted for so long claims otherwise, guess I need to find some new tools.

It seems strange to need a valid <link> in order to detect as a feed?
You could work around it by updating to viewvc trunk - I upstreamed a couple of bugs from bug 387199, and they've fixed them both.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 364677
Verified Duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.