Status

()

Core
Layout: Tables
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: henryfhchan, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5

If i make a page, with a big table, with links at the left, and a statcounter.com script in one of the tds, and a td set to expand so the links and counters are pushed together, but when the page finishes loading, the td set to expand somehow disappears into a 3px height td (including border)  If i maximize/restore the window, it will pack together.

In the other column, I have an iframe set to fill the whole page.

Reproducible: Always

Steps to Reproduce:
create table like this:

table
tr
td height=1px
link
/td
td rowspan="3"
iframe
/td
/tr
tr
td height=1px
counter
/td
/tr
tr
td height="100%"
/td
/tr
/table
Actual Results:  
the td with 100% height shrinks and the other tds expand.  resizing window fixes it.
Just the opposite in Netscape 4.
In Netscape 4 it expands it on resize but firefox expands it on load and shrinks the "Should be shrunken one" back on resize.

Expected Results:  
td with height of 10px should shrink to 10 and td with height of 100% should be expanded at much as it could.
Can you please attach a minimal testcase that shows this problem? (Use the 'Add an attachment' link)
(Reporter)

Comment 2

11 years ago
<html>

<head>
<base target="I1">
<meta http-equiv="Content-Language" content="zh-tw">
<meta name="GENERATOR" content="Microsoft FrontPage 6.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<meta http-equiv="Content-Type" content="text/html; charset=big5">
<title>sixc</title>
<link rel="stylesheet" type="text/css" href="../default.css">
<style>
input{color: #008000; width:200px; height:24px; vertical-align:medium; text-align:center; font:Arial Unicode MS; font-size:12pt}
</style>

<script>
function goToURL(link) { window.hello.location = link; }
</script>


</head>
<body topmargin="0" leftmargin="0" rightmargin="0" bottommargin="0" marginwidth="0" marginheight="0">


    <table background="grd-4px.gif" height="100%" width="100%">
		<tr>
			<td width="200" height="10" style="border-style:none; border-left-width: 0px; border-right-width: 0px; border-top-width: 0px; border-bottom-width: 0px; padding: 0px"></td>
			<td rowspan="11" height="100%">
				<iframe name="hello" width="100%" align="left" frameborder="0" src="frame.html" target="_self" height="100%" marginwidth="1" marginheight="1" style="border:1px solid #91A7B4; background-color:#91A7B4">hello</iframe></td>
		</tr>
		<tr>
			<td width="200" height="24" ><input type=button value="今日功課" onClick="goToURL('homework.html')"></td>
		</tr>
		<tr>
			<td width="200" height="24"><input type=button value="Weather Report" onClick="goToURL('weather.html')"></td>
		</tr>
		<tr>
			<td width="200" height="24"><input type=button value="大家庭" onClick="goToURL('family.html')"></td>
		</tr>
		<tr>
			<td width="200" height="24"><input type=button value="Forum" onClick="goToURL('http://freegb.hkultra.net/gb.php?id=npmps5c')"></td>
		</tr>
		<tr>
			<td width="200" height="24"><input type=button value="班中之星" onClick="goToURL('star.html')"></td>
		</tr>
		<tr>
			<td width="200" height="24"><input type=button value="班中獎項" onClick="goToURL('prize.html')"></td>
		</tr>
		<tr>
			<td width="200" height="24"><input type=button value="今月壽星仔" onClick="goToURL('birthday.html')"></td>
		</tr>
		<tr>
			<td width="200" height="24"><input type=button value="Photo Album" onClick="goToURL('http://picasaweb.google.com/npmps47/')"></td>          
		</tr>
		<tr>
			<td width="200" height="24"><input type=button value="益智遊戲、資料及網站" onClick="goToURL('data_games.html')"></td>
		</tr>
		<tr>
			<td height="100%" width="200"><img border="0" src="../uphand.gif" width="25" height="19"><!-- Start of StatCounter Code -->
<script type="text/javascript" language="javascript">
var sc_project=2265780; 
var sc_invisible=0; 
var sc_partition=20; 
var sc_security="64b7479c"; 
</script>

<script type="text/javascript" language="javascript" src="http://www.statcounter.com/counter/frames.js"></script>
<noscript><a href="http://www.statcounter.com/" target="_blank"><img  src="http://c21.statcounter.com/counter.php?sc_project=2265780&java=0&security=64b7479c&invisible=0" alt="free html hit counter" border="0"></a> </noscript>
<!-- End of StatCounter Code --></td>
		</tr>
		</table></body>

</html>

Updated

11 years ago
Severity: major → normal
Version: unspecified → 2.0 Branch
Please try with a trunk build and report back if you see the problem then
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
this WFM on Trunk 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007073014 Minefield/3.0a7pre

Updated

11 years ago
Component: General → Layout: Tables
Product: Firefox → Core
QA Contact: general → layout.tables
Version: 2.0 Branch → Trunk
(Reporter)

Comment 6

11 years ago
well, fine in latest trunk (18 august, trunk 5).  It works good.  The button  for chinese is slighty smaller than in other versions (same as the weather button), causing the chinese to look like it was pushed down.
(Reporter)

Comment 7

11 years ago
oh the chinese bit was caused by the theme i'm using. sorry about that.
If I use Firefox 2.0.0.6, it gets pushed down and reverts on resize window.
Might be a problem with the script.
Can someone help me analayze what would make it pushed down (the script, which part, or the browser CSS errors?)
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Reporter set to FIXED so I re-resolve as WORKSFORME.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.