Don't migrate all the wallet prefs or the form data file now that wallet is disabled.



12 years ago
10 years ago


(Reporter: standard8, Assigned: standard8)


Dependency tree / graph

Firefox Tracking Flags

(Not tracked)



(2 attachments)



12 years ago
Created attachment 274507 [details] [diff] [review]
The fix v1

Now that bug 304309 has disabled form fill, we should disable migration of some of the preferences and also the form data file.

I would migrate wallet.captureForms to browser.formfill.enabled - however we can't do that because we've flipped the default sense of the wallet.captureForms prefs and short of going to actually parsing the original prefs.js file by hand, I can't actually get the value out.

So what I propose is that for the time being, we don't migrate wallet.captureForms (at all). Once we fix bug 390025 then we'll remove the wallet.captureForms default from browser-prefs.js, so then if the value is set I'll be able to read if, if it isn't set, then it must have been true.

Patch attached removes the redundant code, and adds in a comment noting the above.
Attachment #274507 - Flags: review?(neil)
You're going to hate me for this... I think you patiently created GetSchemaValueFileName and GetSignonFileName to call LocateWalletFile, but now we don't need GetSchemeValueFileName you can merge GetSignonFileName into LocateWalletFile.

Should we in the future expect to be able to migrate form data from Firefox?
Comment on attachment 274507 [details] [diff] [review]
The fix v1

Might want to use & ~ rather than - when dealing with bitmasks.
Attachment #274507 - Flags: review?(neil) → review+

Comment 3

12 years ago
I've checked this in with the & ~ changed. I'll think about Neil's other comments in the next day or so.

Comment 4

12 years ago
Created attachment 276277 [details] [diff] [review]
Remove unnecessary LocateWalletFile function

Removes the now unnecessary LocateWalletFile function.
Attachment #276277 - Flags: review?(neil)
Comment on attachment 276277 [details] [diff] [review]
Remove unnecessary LocateWalletFile function

But I think you would get a smaller patch by moving GetSignonFileName to replace LocateWalletFile.
Attachment #276277 - Flags: review?(neil) → review+

Comment 6

12 years ago
Checked in with the GetSignonFileName function moved down so as to form a smaller diff.
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.