Status

()

P3
major
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: bugzilla, Assigned: dcone)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Build ID: 2000051108

Most widgets now appear to have a thin, inset border around them.  visible in 
URL history dropdown arrow, in numerous places in the prefs dialog, and nearly 
everywhere else.

Comment 1

19 years ago
on linux too. A psudo 3D look with hairy corners. Very appearant in ..Foopy.

Comment 2

19 years ago
So, it appears that a change to the calculation of -moz-border-radius
results in the change to the <button> appearance. (I initially thought
it was just more funky css from ben :-]).

Attaching a screenshot comparing the appearance of a simple <button>
style (based on what is in button.css): The left hand side is a May 11
win32 build, the right hand side is May 10. Top to bottom the four
buttons are:

              
 |  button                               |  button > .button-internal-box
-|---------------------------------------|--------------------------------
1| -moz-border-radius: 3px 2px 2px 3px;  |  border: 1px outset #CCCCCC;
2| -moz-border-radius: 0px 0px 0px 0px;  |  border: 1px outset #CCCCCC;
3| -moz-border-radius: 3px 2px 2px 3px;  |  border: 1px solid  #CCCCCC;
4| -moz-border-radius: 0px 0px 0px 0px;  |  border: 1px solid  #CCCCCC;
-|---------------------------------------|--------------------------------


 2 and 4 have the same appearance; 1 and 3 do not (with 1 being the standard
 set of styles for a button).

---
The XUL for this image is :

<?xml version="1.0"?> 

<?xml-stylesheet href="button.css" type="text/css"?>


<window xmlns:html="http://www.w3.org/TR/REC-html40"
	xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
	xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
	align="horizontal" style="padding-top:20px;">

    <box orient="vertical">
      <button value="Sample Text" />
      <button value="Sample Text" id="no-outer-radius" />
      <button value="Sample Text" id="inner-box-solid" />
      <button value="Sample Text" id="no-outer-radius-inner-box-solid" />
    </box>			      

</window>


---
The CSS for this image is :

  button {
      border              : 1px solid #000000;
      -moz-border-radius  : 3px 2px 2px 3px;
      margin              : 1px;
      background-color    : #CCCCCC;
  }
  button > .button-internal-box {
      border              : 1px outset #CCCCCC;
      padding             : 2px;
  }
  button#no-outer-radius {
      -moz-border-radius  : 0px 0px 0px 0px;
  }
  button#inner-box-solid > .button-internal-box {
      border              : 1px solid #CCCCCC;
  }
  button#no-outer-radius-inner-box-solid {
      -moz-border-radius  : 0px 0px 0px 0px;
  }
  button#no-outer-radius-inner-box-solid > .button-internal-box {
      border              : 1px solid #CCCCCC;
  }
    
---
Adding nsbeta2 for beta 2 consideration.   
Assignee: trudelle → ben

Comment 3

19 years ago
Created attachment 8640 [details]
screenshot; LHS May 11 -- RHS May 10 -- buttons change in appearance

Comment 4

19 years ago
adding nsbeta2 keyword
Keywords: nsbeta2
don, was this caused by your rounding change checkin on May 10? I talked to 
evaughan and he seemed to think it was. 
Assignee: ben → dcone
Severity: normal → major
*** Bug 39021 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M16
(Assignee)

Comment 7

19 years ago
I had a fix in for some pixel thick framing.. somehow this is being called when 
buttons are asked to paint.  I took out this code.. but I have to find out why 
buttons are asking for 1 pixel lines to be painted. 
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

18 years ago
vrfy fixed in new win98 build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.