Personal Folders message corruption.

RESOLVED DUPLICATE of bug 390691

Status

MailNews Core
Database
--
critical
RESOLVED DUPLICATE of bug 390691
11 years ago
9 years ago

People

(Reporter: Dylan Thomas, Assigned: Bienvenu)

Tracking

({dataloss, qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: version 2.0.0.5 (20070716)

Note: I was a programmer/analysis with an IBM software testing & development team. I've tried to track down the cause of the following bugs and realize I do not have sufficient tools.

I imported personal folder data from Outlook 2002 into Thunderbird. Data was compacted and not corrupted before import. No error messages during import, bugs gradually appearing and remaining after four Thunderbird updates.

I'm seeing two types of personal folder message corruption in the build listed above and three previous builds. I've allowed Thunderbird to update each time it indicates a new update is available.

Bug 1.) In four separate personal folders, double clicking to view the most recent 4-5 messages opens up an unrelated message from another folder, that was DELETED weeks ago. Same deleted message showing up in three different folders.

Deleting the corrupted recent messages moves the corruption to older messages in the same folders. Compacting the folders has no effect on this problem.

I created new folders and moved existing messages to new folders. Corruption moved to new folders.

Corrupted folders contain ~100 messages.

2.) Multiple copies of the same message appears at random in different folders. I'm deleting all but one of the copies and compacting folders. Corruption continues to appear.

Database corruption continues to grow. No tools available to further diagnosis or fix. Suggestions?



Reproducible: Always

Steps to Reproduce:
1.Double click message in personal folder.
2. Previously deleted, unrelated message appears instead of correct message.
3. Browsing other personal folders seeing multiple copies of random messages.
Actual Results:  
Deleting corrupted messages and moving other messages to new folders has no effect on problems. Data corruption is growing. Compacting folders has no effect. Folders contain ~100 messages.


Outlook 2002 data appears to have been corrupted during or after import. Need additional tools to diagnosis problems. Screen shots of corruption available
QA Contact: build → build-config
(Reporter)

Comment 1

10 years ago
Corruption spread through entire database, lost data and ended up uninstalling package. Resumed using Outlook 2002 and have not seen any corruption of the data imported into Thunderbird.
Not a build config bug.
Component: Build Config → General
Keywords: qawanted
QA Contact: build-config → general
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> Not a build config bug.
> 
If not a build config bug, its an import bug, or how would you classify it?

I deleted and reinstalled Thunderbird from another download, imported new data from Outlook 2002 and the corruption problem reappeared.

Comment 4

10 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > Not a build config bug.
> > 
> If not a build config bug, its an import bug, or how would you classify it?

=> database


bug 390691 might be a dupe, but keeping both open for now.
Assignee: nobody → bienvenu
Blocks: 390691
Component: General → MailNews: Database
Keywords: dataloss
Product: Thunderbird → Core
QA Contact: general → database
Product: Core → MailNews Core

Comment 5

9 years ago
Dylan, the problem appears only *after* you import outlook data, and happens immediately?
(Reporter)

Comment 6

9 years ago
Wayne, I *gradually* noticed the problem(s) when I opened messages, not all at once.

At first double clicking the most recent 4-5 messages opened up an unrelated previously DELETED message from another folder. (Ex: I'd see a deleted message from "XYZ" folder when clicking to view new Inbox messages.) I'd see the same deleted message in up to three different folders. Eventually I went through an entire folder and every message was corrupted with the same data.

Then *gradually* I started seeing part of a Verisign logo image downloaded from the web by Firefox instead of the message. I regularly emptied browser caches and temporary files and did not find the .gif(?) stored on the computer.

Comment 7

9 years ago
for sanity's sake, duping to bug 390691.  If that turns out to be a bad move, we can always undupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 390691
You need to log in before you can comment on or make changes to this bug.