can't start dragging before selection is shown on screen

RESOLVED WORKSFORME

Status

Calendar
Calendar Views
--
minor
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Taraman, Unassigned)

Tracking

Trunk
x86
Windows XP

Details

(Reporter)

Description

11 years ago
If you start dragging before the event you click on is highlighted on the screen the drag-process doesn't start.

Steps to reproduce:
1. go to week view
2. select a different day than the one with the event.
3. click and hold the event.
4. immediately start moving the mouse away from the event.
5. If you are quick enough the display remains the same.
6. while still holding the mouse return the pointer over the event
7. dragging satrts

I believe this works in all the views, but with the right day already selected you are not quick enough.
I can't reproduce this behavior with Tb 2.0.0.6pre + Lightning 0.7pre (2007073105) on WinXP and a local storage calendar.

Markus, what versions of Thunderbird and Lightning did you use? 
(Reporter)

Comment 2

11 years ago
I did it with TB 2.0.0.5 Portable edition and Lightning 0.7pre (2007073105)
Also with Sunbird 0.7pre Build 20070731
Keywords: qawanted

Comment 3

11 years ago
I can reproduce the behaviour. Step 2 should say: Select a different day and a different event.
After that click the test event and dragging the mouse around does nothing. If I move the mouse over the event once more (still pressing down the left button) the expected behaviour starts. That is, I see a shadow of the event moving around.
I can't reproduce the issue using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090125 Calendar/1.0pre.

Markus, Sebastian: Can you still reproduce?
(Reporter)

Comment 5

10 years ago
With TB 2.0.0.17 Portable and 0.9 PRE build 2008100821 (last available for TB2 I think) I can't reproduce the Problem.
When I do the described steps, now the dragging starts with a delay (this is because I start it from an USB.Stick), but it performs as expected.

I would say "resolved"
Thanks for retest. Resolving as WFM.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.