Fonts in plain text mail (with variable font option) reader smaller than in browser

RESOLVED WORKSFORME

Status

MailNews Core
MIME
P3
normal
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: BenB, Assigned: rhp (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I have helvetica 14 as sans-seirf font, "use sans-serif for variable width" and
"use variable width for plain text msgs" sat in the prefs. In the browser, fonts
look like 14 pt. However, if I view a plain text msg, it is displayed in a
fonts, that looks like 10 pt.

Comment 1

18 years ago
I think this is dupe of #28274.
(Reporter)

Comment 2

18 years ago
miri, no, this (39037) bug has been caused by a DUP of bug 28274. I.e. 28274 has
bascially been fixed, but in a way, which caused this (39037) one. But tnx for
paying attention.

Comment 3

18 years ago
Has 28274 been fix? I think this happens without my changes.
This is because <pre> or <tt> are used for plain text cases. We may change the 
code to use <div> in case variable font is selected for plain text view.
For <pre wrap>, <div white-space: pre> can be used.
Reassign to mozilla@bucksch.org (Ben Bucksch) owner of 28274.
 
Assignee: nhotta → mozilla
Summary: Fonts in mail reader smaller than in browser → Fonts in plain text mail reader smaller than in browser
(Reporter)

Comment 4

18 years ago
> Has 28274 been fix?



I thought, it had been fixed with your changes for bug 26182.



Comments From nhotta@netscape.com 2000-04-21 16:37 in bug 26182:

> If above pref is "false" then you can apply mail/news specific font setting

> by following prefs.

> "mailnews.font.name.html"

> "mailnews.font.size.html"

> "mailnews.font.name.plain"

> "mailnews.font.size.plain"



[tags]



I really see no need to add anything other than a div or span. We already do set

pre or whatever is needed in the content-specific converters. I need to select

the correct font family, but that's all.



> Reassign to mozilla@bucksch.org (Ben Bucksch) owner of 28274.



I'm not the owner of 28274. This is not my bug. Even if I knew how to do it, I

would have no time to fix it. Sorry. Back to you, nhotta.

Assignee: mozilla → nhotta
(Reporter)

Comment 5

18 years ago
> I need to select the correct font family, but that's all.



*You*, of course.



If you have to use a tag in bug 26182, there's a bug anywhere, I think. Either

in your code or in the converters (I could help with the latter).

Comment 6

18 years ago
>I'm not the owner of 28274. 
Okay, that was my misunderstanding. But bug 26182 was not for fixing the size 
issue. That problem has been existing before 26182 change.
Reassign to rhp, please reassign to the owner of the plain text view code.
Assignee: nhotta → rhp
Summary: Fonts in plain text mail reader smaller than in browser → Fonts in plain text mail (with variable font) reader smaller than in browser

Updated

18 years ago
Summary: Fonts in plain text mail (with variable font) reader smaller than in browser → Fonts in plain text mail (with variable font option) reader smaller than in browser
(Reporter)

Comment 7

18 years ago
nhotta, you're right, this bug exists in M15. Sorry for blaming you.

Dunno, where this small font comes from. If it's in the MIME plain text
converter, tell me and I'll take care of it.
(Reporter)

Comment 8

18 years ago
Seems to be fixed. Need further testing, though.
(Assignee)

Comment 9

18 years ago
Seems to work.

- rhp
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.