Mail thinks that my folders in Inbox are nested inside each other (which is wrong) and subsequently can't find mailboxes because it has gotten the hierarchy wrong - only folders inside Inbox affected.

RESOLVED INVALID

Status

RESOLVED INVALID
12 years ago
10 years ago

People

(Reporter: j.smerdon, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

My real Inbox folder hierarchy is Inbox -> Diamond, CMA, Liverpool, Football, Physics, Travel; CMA -> Nancy.  Mail gets this as Inbox -> Diamond, Liverpool, Physics, Travel; Diamond -> CMA, Liverpool -> Football, Physics -> Travel, Travel -> CMA; Diamond -> CMA -> Nancy.  These folder hierarchies are totally different, and now Mail can't find my messages because it looks in places that don't exist.

Reproducible: Didn't try

Steps to Reproduce:
1. Download SeaMonkey (I'm not being facetious, it just happened the first time I downloaded)
2. Try to connect to my IMAP account (which by the way uses SSL encryption)

Actual Results:  
Get a wrong folder hierarchy. Everything in the root is fine, but everything nested one below in the Inbox is not.

Expected Results:  
Mail should download the correct folder hierarchy and thus keep a mailbox consistent with all the other clients I use (Outlook, OWA, Mac Mail). BTW Thunderbird was always OK.

Computer has just had a fresh (tonight) install of XP SP2.  Programs running are Spybot S&D, AVG Free, uTorrent, Firefox, IE5.
Which product/version are you using ?

Can you reproduce with SeaMonkey v1.1.9 ?
(1 month later)

No reply from reporter.

(Would have been "Incomplete", now is) R.Invalid

Reopen if you can reproduce with SeaMonkey v1.1.9.
(or SeaMonkey v2.0a1pre ?)
Assignee: mail → bienvenu
Component: MailNews: Main Mail Window → Networking: IMAP
Product: Mozilla Application Suite → Core
QA Contact: networking.imap
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.