Select menus open on the wrong spot

RESOLVED FIXED

Status

()

Core
XUL
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: Ria Klaassen (not reading all bugmail), Assigned: Neil Deakin)

Tracking

({regression, testcase})

Trunk
x86
All
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Steps to reproduce:

- Put the following line in userContent.css:
:focus { outline: 1px dotted black
!important;}
- Login to your GMail account and click on the arrow of the select box on top "More actions..."

Result: menu opens far to the left
When you click once more the menu opens on the right spot

For a screenshot see https://bugzilla.mozilla.org/attachment.cgi?id=273468

Updated

11 years ago
Flags: blocking1.9?
Keywords: testcase
OS: Windows XP → All
(Assignee)

Comment 2

11 years ago
Created attachment 274768 [details] [diff] [review]
fix

Seems that <select> also uses a popupList. As other parts of the frame constructor also assume that this list is only used for xul popups, the easiest fix here is to just use a different list for <selects>.
Assignee: jag → enndeakin
Status: NEW → ASSIGNED
Attachment #274768 - Flags: superreview?(dbaron)
Attachment #274768 - Flags: review?(dbaron)
bz is probably a better reviewer for this than I am.
(Assignee)

Updated

11 years ago
Attachment #274768 - Flags: superreview?(dbaron)
Attachment #274768 - Flags: superreview?(bzbarsky)
Attachment #274768 - Flags: review?(dbaron)
Attachment #274768 - Flags: review?(bzbarsky)
Comment on attachment 274768 [details] [diff] [review]
fix

r+sr=bzbarsky.  I assume the problem is that we were skipping the child view positioning?
Attachment #274768 - Flags: superreview?(bzbarsky)
Attachment #274768 - Flags: superreview+
Attachment #274768 - Flags: review?(bzbarsky)
Attachment #274768 - Flags: review+
(Assignee)

Updated

11 years ago
Attachment #274768 - Flags: approval1.9?
Comment on attachment 274768 [details] [diff] [review]
fix

a1.9=dbaron
Attachment #274768 - Flags: approval1.9? → approval1.9+
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

9 years ago
Flags: blocking1.9?
You need to log in before you can comment on or make changes to this bug.