Draft emails not removed from draft folder after mail is sent

RESOLVED DUPLICATE of bug 402132

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 402132
11 years ago
8 years ago

People

(Reporter: Seth Bindernagel, Unassigned)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
When I compose a mail, Thunderbird autosaves a copy in the Draft folder of the message before it is sent.  After the message is sent, the draft remains in the draft folder.

This definitely happens with my Mozilla mail account (LDAP).  Not sure yet it it happens with my Gmail account (POP).

Pictures of the Draft and Sent folders are attached from Thunderbird version 2.0.0.5 (20070716) on Mac OSX.
(Reporter)

Comment 1

11 years ago
Created attachment 274813 [details]
Screen shot of Draft folder
(Reporter)

Comment 2

11 years ago
Created attachment 274815 [details]
Screen shot of Sent Folder
Can you execute "Edit Draft" for the remaining Draft mail?
What will happen when you click other folder than Drafts folder then click Drafts folder again?
Isn't it simply a phenomenon after mail send when Bug 382517 occurs?

Bug 382517 seems to be already resolved on trunk. Can you re-produce your problem with latest trunk nightly?
(Reporter)

Comment 4

11 years ago
(In reply to comment #3)
> Can you execute "Edit Draft" for the remaining Draft mail?

"Edit Draft" works for the draft mail that remains in the draft folder.

> What will happen when you click other folder than Drafts folder then click
> Drafts folder again?

After clicking on other folders and then returning to the Draft folder, the drafts all remain in the Draft folder and are able to be edited with the "Edit Draft" button.

> Isn't it simply a phenomenon after mail send when Bug 382517 occurs?
> 
> Bug 382517 seems to be already resolved on trunk. Can you re-produce your
> problem with latest trunk nightly?

It isn't multiple copies of the same draft...the new problem is that the draft remains in the Draft Folder after the message is sent.  The multiple drafts in the draft folder seems to have been resolved with Bug 382517.  I believe this is a new and unique bug, but I may be wrong.  Any other test suggestions?

> 

When Tb latest trunk(I couldn't observer Bug 382517), behavior was as follows;
 1. Compose a mail(subject=001), save as Draft => 1 draft(001) in thread pane
 2. Edit draft, change subject to "002", then auto-save
    => when confirmation dialog after save : 2 drafts( 001 & 002)
    => after close of confirmation dialog  : 1 draft only (001 disappeared)
    => when confirmation dialog after save : 2 drafts (002 & 003)
    => after close of confirmation dialog  : 1 draft only (002 disappeared)
 3. Send Later => draft(003) disappered

Remained draft is original one? Or auto-saved'ed one?  
Can you re-produce your problem with latest trunk nightly?
(test with new profile, dummy POP3 account is recommended)
> This definitely happens with my Mozilla mail account (LDAP)

Chatting with SethB, he meant to write IMAP.
To Seth Bindernagel(bug opener):
Can you get IMAP protocol log(with 2.0.0.5) when send after auto-save?
 http://kb.mozillazine.org/Session_logging_for_mail/news
 http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
(change "protocol:5"=>"imap:5,smtp:5". attach log as plain/text instead of paste)
Even if problem don't occur, log of normal flow is important for problem analysis by developers.
 
Oh sorry. You were a Mac user.
To Seth Bindernagel:
Please see "OS X" section of next page for how to invoke NSPR logging on Mac OS X.
  http://www.mozilla.org/projects/netlib/http/http-debugging.html

Comment 9

11 years ago
Created attachment 286972 [details]
debug session log

I am seeing the same behavior on Windows XP with my Gmail IMAP account configured in Thunderbird like this:
http://lifehacker.com/software/geek-to-live/turn-thunderbird-into-the-ultimate-gmail-imap-client-314574.php

Windows XP
Thunderbird 2.0.0.6 (20070728)

I have attached a log (removed personal info) from a test session.
(In reply to comment #9)
> I am seeing the same behavior on Windows XP with my Gmail IMAP account

When Gmail IMAP, it's bug of Gmail IMAP, and DUP of Bug 402132.
See dependency tree for meta Bug 402793. (with "Show Resolved")

Is there any other issues than Bug 382517 & Bug 402793 in your problem?  

Comment 11

11 years ago
Sounds like a similar bug I am experiencing.  I deleted a draft e-mail from the draft folder, but the 'All Folders'  Shows a bolded '(1)' near the 'Drafts' folder.  While there are no drafts in the folder at all.

Attached log is for Gmail IMAP, and no answer to question of Comment #10.
Closing as DUP of Bug 402132.

(In reply to comment #11)

To Robert Warner:
Phenomenon you are seeing is a result of special design/behaviour of Gmail IMAP when usual delete. (This bug & Bug 402132 is for Gmail IMAP bug when internal delete of draft mail by new auto-save or mail send.)
See dependency tree for meta Bug 402793 (with "Show Resolved"), and read documents by Google/Gmail pointed in the meta bug, please.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 402132

Comment 13

11 years ago
I encounter the same symptoms as first reported.  I have auto save set to 3 minutes.  As I compose a message, auto saves are placed in the drafts folder every 3 minutes.  When the message is successfully sent, the auto saves of the message are left in the drafts folder.  If I don't clean out the folder, it builds up to be very large.

Configuration: Windows XP SP2, mail server: Novell's NetMail, using IMAP.  The drafts folder is on the mail server as a part of the IMAP account.

Comment 14

11 years ago
John: probably bug 382517.
You can attach an imap log there, http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
You need to log in before you can comment on or make changes to this bug.