Right Click "Save Image" and download manager do not work with corrupt empty downloads.rdf

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Don Harshman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME (after corrupt downloads.rdf analysis))

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Last night an update came in on 2.0.0.4.  Shortly after I couldn't download images off internet sites.  I updated to 2.0.0.6 and same problem.  I can do the downloads using IE 7.0.  I would right click on the image and select the "Save Picture As" and accept or enter an image ID.  It would seem to save but Download Mgr didn't pop up and the image file wasn't saved, as a JPEG or anything else -- when I opened the Download Mgr manually it was empty.  I looked at all the settings to see if there was something inadvertently turned off, but no.  And it didn't matter which website I was on.  This was working absolutely fine early yesterday morning before the auto update kicked in.

Reproducible: Always

Steps to Reproduce:
1.Right click on an image on a website and select "Save Picture As"
2.Save the picture
3.Check the download folder (I tried different ones) and you'll see the image isn't saved
4.  Check Error Console and you should see the error below
Actual Results:  
No image saved.  Download Mgr does not pop-up.  Error Console shows the following:

Error: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsITransfer.init]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: chrome://global/content/contentAreaUtils.js :: internalSave :: line 352"  data: no]

Expected Results:  
Image saved in location with either the default image ID or the "save as" name, defaulting to .JPG type.

Save the picture after accepting or renaming the image.  Download Mgr should have been triggered and popped up -- it did not.  The same images I could save yesterday morning and I can still save them via IE 7.
(Reporter)

Comment 1

10 years ago
Thank you for looking into this.

Comment 2

10 years ago
IT could be an extension, could you try in Safe Mode? (http://kb.mozillazine.org/Safe_Mode)
(Reporter)

Comment 3

10 years ago
Everything else seems to be running fine, including IE7 (well, as good as IE7 runs) but I will try it in Safe mode and let you know.  Thank you.
(Reporter)

Comment 4

10 years ago
As I requested I brought my system up in Safe Mode (both in regular and w/ Networking).  In neither case could I save an image; not even on pages stored locally.  Download Mgr did not come up.  After attempting the save the Error Console displayed the same error message.

Note:  I have run McAfee, SpySweeper and Spybot Search and all three came up clean.

I'm open to suggestions; perhaps scrubbing Firefox off my system completely and reinstalling?

Thanks.  Don

Comment 5

10 years ago
try following these suggestions:
http://kb.mozillazine.org/Unable_to_save_or_download_files

please make a backup of your downloads.rdf and if deleting that works attach here for investigation
(Reporter)

Comment 6

10 years ago
Created attachment 275223 [details]
As requested, am attached a copy of the problematic downloads.rdf

Per your suggestion I deleted downloads.rdf after making a copy.  Deleting it worked.  By the way using "downloads.rdf" as the search key word lead me right to the article "Unable to save or download files"; which I couldn't find in my original searches of Mozillazine.  Maybe a few more key words on the doc would pop it up more readily.  Thank you for you help.  I'd be curious to know why this file created "issues" for me. -- Don

Comment 7

10 years ago
this should be closed as WFM but i'm leaving open for now, in case someone wants to investigate a way to not make this happen with such an empty downloads.rdf
Severity: major → normal
Summary: Right Click "Save Image" doesn't work, Download Mgr doesn't execute, Error Console shows error: → Right Click "Save Image" and download manager do not work with corrupt empty downloads.rdf

Comment 8

10 years ago
I was heartened to see that someone else was having the same problem I was having. I have one further complication, though: I don't have "downloads.rdf" in my Profile folder. I've checked several times and have uninstalled Firefox several times to see whether it would regenerate the downloads.rdf file on its own. I've installed earlier versions of Firefox as well, but nothing seems to work. I'm running the latest version of Firefox 2.0.0.6 on Windows Vista Home Premium. Does it make sense to anyone that I would not only not have the downloads.rdf file but also not be able to recreate it? 

Comment 9

10 years ago
it should be created on the first download

Comment 10

10 years ago
My bad. I wasn't paying close enough attention to what I was doing. It works for me now. 

Updated

10 years ago
Whiteboard: CLOSEME (after corrupt downloads.rdf analysis)
I dropped in the downloads.rdf file into my current in-development version of Firefox 3's profile directory, and we're fine with converting it and saving.

This should be fixed in Firefox 3.  Marking worksforme; thanks for reporting bugs!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.