Cookies seem to die instantly

RESOLVED INVALID

Status

RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: aberg010, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007080104 Thunderbird/3.0a1pre

Using Thunderbrowse (https://addons.mozilla.org/en-US/thunderbird/addon/5373), I am able to log into a website (e.g. AMO), but only the first page loaded shows me as logged in. I do not know if this is a Thunderbrowse bug or not (I have notified the TB author). If there is some other test you can give, I'll post results.

Reproducible: Always

Steps to Reproduce:
1. Open a webpage via Thunderbrowse
2. Log into that site
3. Visit any page
Actual Results:  
I do not stay logged in.

Expected Results:  
Kept me logged in.

With Thunderbrowse enabled, the info box/URL bar is not visible with only it enabled. However, with some combination of these extensions enabled the info box and URL are visible. This is probably a Thunderbrowse bug.

Generated: Wed Aug 01 2007 20:54:45 GMT-0500 (Central Daylight Time)
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007080104 Thunderbird/3.0a1pre ThunderBrowse/3.0.1
Build ID: 2007080104

Enabled Extensions: [11]
- Display Mail User Agent Extension 1.3.2: http://www.cweiske.de/misc_extensions.htm#dispMUA
- FoxClocks 2.1.93: http://www.stemhaus.com/firefox/
- FoxyTunes 2.9.2: http://www.foxytunes.com/
- Link Properties for Thunderbird 0.2: http://gamespotting.net/networks/projects
- Mail Redirect 0.7.4: http://mailredirect.mozdev.org
- Maximize Message Pane 0.9.70: http://www.geocities.jp/wknxc134/moz_ext/
- Menu Editor 1.2.3.3: http://menueditor.mozdev.org/
- MR Tech Local Install 5.3.2.5: http://www.mrtech.com/extensions/local_install/
- Remember Mismatched Domains 1.4.3: http://www.andrewlucking.com
- Thunderbird Biff 2.1.3: http://thunderbirdbiff.mozdev.org/
- ThunderBrowse 3.0.1: http://gamespotting.net/networks/projects

Disabled Extensions: [14]
- Adblock Plus 0.7.5.1: http://adblockplus.org/
- Adblock Plus: Element Hiding Helper 1.0.1: http://adblockplus.org/
- Contacts Sidebar 0.7: http://jpeters.no-ip.com/extensions/?page=tb_cs
- CS Lite 1.0.7 Preview: http://forum.softwareblaze.com
- CuteMenus - Crystal SVG 1.9.1: http://www.cutemenuproject.com/
- DownThemAll! 0.9.9.10: http://www.downthemall.net
- Extension Manager Extended 2.6.1: http://extended.spanglerco.com/
- Fast Mail Redirect 0.4.1: http://www.aloetscher.ch/
- Leet Key 1.3.5: http://leetkey.mozdev.org
- Spamato4Thunderbird 0.99.1.3: http://www.spamato.net/
- Update Notifier 0.1.5.3: http://www.longfocus.com/firefox/updatenotifier
- VeriSign EV Green Bar Extension 1.0.1.2814: http://www.verisign.com/
- WebMail 1.2.3: http://webmail.mozdev.org
- WebMail - Yahoo 1.2.1: http://webmail.mozdev.org

Total Extensions: 25

Installed Themes: [3]
- Phoenity 0.2.5: http://phoenity.com/
- PitchDark 2.0.1: http://cgi2.cs.rpi.edu/~banket/projects/pitchdark/
- Thunderbird (default): http://www.mozilla.org/

Installed Plugins: (3)
- Microsoft® DRM
- Shockwave Flash
- Windows Media Player Plug-in Dynamic Link Library

The default theme was used.
Dupe of bug 236954? Bug 275131 (should have) added support for it...
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
Given the discussion in https://addons.mozilla.org/en-US/thunderbird/discussions/comments.php?DiscussionID=6424&page=1#Item_0 the date of this bug and the extensions in use (the main ones being Thunderbrowse and CS Lite in this case), this is more likely a problem with Thunderbrowse than Thunderbird's cookie handling - Thunderbird disables all cookies apart from RSS by default. From that discussion it appears Thunderbrowse overrides this in some manner.

Therefore resolving this as invalid as it is/was most likely a fault in the extension. If the extension author has a specific problem with Thunderbird, then they are quite welcome to file a bug on that and we can look at fixing it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.