first letter's part hidden in input type="text" arial 11px

RESOLVED WORKSFORME

Status

()

Core
Layout
--
trivial
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Simon, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

If I use Arial font for input type="text" and set font-size:11px; then if first letter is W first pixel of W letter disappears.
I didn't notice problems with other fonts.
There is no problem on IE or Opera.

Reproducible: Always

Steps to Reproduce:
1. Write HTML <input type="text" value="Window" />
2. Write CSS INPUT { font-size:11px; font-family:Arial; }
3. That's all
Actual Results:  
W letter's part is hidden.

Expected Results:  
Whole W letter should be showed :)

As I written before, it happens only with Arial 11px.

Comment 1

11 years ago
This is a Branch only bug, fixed in Trunk (test with a current nightly build)

probably not worth fixing in branch, it will not receive fixes to trivial problems
Severity: normal → trivial
Whiteboard: CLOSEME?
Version: unspecified → 2.0 Branch

Comment 2

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007080204 Minefield/3.0a7pre

Yeah, this issue is fixed on trunk. Resolving as WORKSFORME since there's a low probability of this fix going in on branch, even if we figured out what fixed it.

->WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Resolution: --- → WORKSFORME
Whiteboard: CLOSEME?
Version: 2.0 Branch → 1.8 Branch

Updated

11 years ago
Version: 1.8 Branch → Trunk
You need to log in before you can comment on or make changes to this bug.