Tables with "border-collapse: collpase" 1px displacement

RESOLVED DUPLICATE of bug 155955

Status

()

Core
Layout: Tables
--
minor
RESOLVED DUPLICATE of bug 155955
11 years ago
11 years ago

People

(Reporter: Mikhail E Krasilnikiov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.5) Gecko/2007071317 Firefox/2.0.0.5

If table CSS property "border-collapse" set to "collapse", and document has DTD, table displaces by 1px top and left.

Reproducible: Always

Steps to Reproduce:
1.Insert in document any DTD (e.g. HTML 4.01 Transitional)
2.Insert in document any block element with a visible border
3.Insert table after it
4.Set table's border visible and set CSS property "border-collapse" to "collapse"
Actual Results:  
Table top border overlays div bottom border
Table left border is displaced by 1px to the left relative to div left border

Expected Results:  
Left borders of div and table must be on one vertical line
Div bottom border must be not overlayed by table

This problem take place only if DTD was specified
And I think bug 322236 has a something similar

Comment 1

11 years ago
Please attach a testcase that shows the problem.  Use the "Add an attachment"
link on the bug report.  Thanks.
Probably the standards-mode placement of the outer edge of the table in the middle of the border, something that was changed in recent editions of CSS2.1.  If so, I think this is a duplicate.
(Reporter)

Comment 3

11 years ago
Created attachment 276462 [details]
testcase
(Reporter)

Comment 4

11 years ago
Created attachment 276463 [details]
Without DTD

And this is expected result
(Reporter)

Comment 5

11 years ago
Created attachment 276464 [details]
Without DTD

Sorry! Previous attach invalid. And this is expected result.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 155955
You need to log in before you can comment on or make changes to this bug.