creating a new bookmark adds it to the parent folder, not the selected folder

RESOLVED DUPLICATE of bug 387035

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 387035
11 years ago
8 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

creating a new bookmark adds it to the parent folder, not the selected folder

steps to reproduce:

1) open boomarkmanager
2) in the left hand pane, create a folder "foo", the child of "Bookmarks"
3) select "foo"
4) create a bookmark

expected results:  new bookmark added to "foo"
actual results:  new bookmark added to "Bookmarks"

I'm seeing this with:  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007073005 Minefield/3.0a7pre

this seems like a relatively recent regression.  (related to the txn manager?)
Flags: blocking-firefox3?

Comment 1

11 years ago
select "foo" in the right hand pane or left hand pane?

if you're selecting "foo" in the left hand pane, this is fixed by bug 387035

if you're selecting "foo" in the right hand pane, that's because "foo" is a closed folder, and not an opened one - it'll only be created inside "foo" if you double click, "opening" the folder (unfortunately, it's hard to see the difference visually, at least on OS X, but... that's the way it is right now).
> select "foo" in the right hand pane or left hand pane?

left hand pane.  so should I mark it as a dup?

as for the right hand pane, I see what you mean, and I see what you wrote in comment #1.

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 387035

Updated

11 years ago
Flags: blocking-firefox3?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.