If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Camino spends ages waiting for srx.de.ebayrtm.com

VERIFIED WORKSFORME

Status

Camino Graveyard
General
VERIFIED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Klaus Stampa, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de; rv:1.8.1.4) Gecko/20070509 Camino/1.5 (MultiLang)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de; rv:1.8.1.4) Gecko/20070509 Camino/1.5 (MultiLang)

when performing a search on ebay.de, Camino will not display the results but wait ages (and I mean ages! I waited for 5 minutes) for srx.de.ebayrtm.com.

as soon as I start a new search the results get displayed for the short time until Camino tries to load the new results.

ebay.com (srx.main.ebayrtm.com) works. ebay.de works with Netscape Navigator 9 beta.

I should add that I am on a UMST/3G and thus probably high latency connection.

Reproducible: Always

Steps to Reproduce:
1.open Camino
2.go to ebay.de
3.search for anything
4.wait...
Actual Results:  
Camino did not display the results

Expected Results:  
Camino should have displayed the search results

Comment 1

10 years ago
I logged into my eBay account but on the DE servers on:
Host: search.ebay.de

using:
Version 2007080300 (1.6a1pre)
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.7pre) Gecko/20070803 Camino/1.6a1pre (like Firefox/2.0.0.7pre)


and made several successful searches on various products such as "garmin gps", then "nike" and so forth

all results displayed instantly.

Comment 2

10 years ago
I would be curious to know if this is a problem with Firefox 2 (or really any other Gecko browser roughly equivalent to Camino 1.5), especially in light of the possible connection issue.

eBay is fairly well-known for doing extremely shady sniffing (based on accept-lang headers, reverse DNS lookups to determine country of origin, etc.) so it wouldn't surprise me at all if this was only a problem with an IP address that resolves to a German host. I don't ever see the host in question when doing a search on eBay.de from a US-based IP address. (It may have gone by too fast to notice, but I didn't see it at all.)

There's also an outside chance that this was a transient server problem. Please try it again and see if you can still reproduce it.

cl
(Reporter)

Comment 3

10 years ago
Created attachment 275235 [details]
screenshot
(Reporter)

Comment 4

10 years ago
It is still reproducable here in 1.5, see the attachment.

And still Navigator 9 does not show this kind of behavior.

But then I downloaded the nightly (Version 2007080400 (1.6a1pre)) and there it does no longer exist. All results are displayed instantly.

Sorry for all the fuss, it seems resolved to me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
This does seem like it might be TE, but since there's no code change, so WORKSFORME, not FIXED.
Resolution: FIXED → WORKSFORME

Comment 6

10 years ago
At least, no code change that we know about ;)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.