Proxy authentication is required a second time after updating extensions on startup due to the app needing to restart

VERIFIED FIXED in mozilla2.0b2

Status

()

--
enhancement
VERIFIED FIXED
12 years ago
8 years ago

People

(Reporter: paolo.marani, Unassigned)

Tracking

Trunk
mozilla2.0b2
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; FDM; InfoPath.1; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30)
Build Identifier: FF 2.0.0.6

When user is behind a proxy, thanksfully to the resolution of bug 312473, if an extension need to be updated at startup the proxy auth request will popup.
Unfortunately, after the extension has been updated, when FF restart the proxy auth is requested again accessing the first page. Credential are not cached.
The request is to cache proxy auth request and/or introduce a preference option to automatically send proxy auth requests without user intervention, when those informations have been validated by a previous successfully proxy auth.

Reproducible: Always

Steps to Reproduce:
1. Put FF behind a proxy, having an extension requiring upd
2. Start FF, confirm auth request, download extension update
3. FF will restart and reask auth upon first url loaded
Actual Results:  
User are promted twice for auth

Expected Results:  
User should be prompted only once

A better behaviour would be to have a preference for authomatic authentication without any pre-filled username/password.
(Reporter)

Comment 1

12 years ago
Added cc to robert as requested
Depends on: 312473
note: the solutions regarding caching are beyond the scope of fixing this bug.
Blocks: 366777
Status: UNCONFIRMED → NEW
Component: General → Extension/Theme Manager
Ever confirmed: true
QA Contact: general → extension.manager
Summary: Proxy authentication requested twice when updating extensions and reload FF → Proxy authentication is required a second time after updating extensions on startup due to the app needing to restart
I can take a look over this to see if it's anything obvious. I suspect the issue is lacking a window inside of the xpinstall code that calls the authentication dialog.
Component: Extension/Theme Manager → Installer: XPInstall Engine
Product: Firefox → Core
QA Contact: extension.manager → xpi-engine
Version: unspecified → Trunk
Dave, wouldn't this be due to the application restarting after the first authentication?
Thanks Rob, that's a far more likely, if not defiantly the scenario. And it also probably makes it quite difficult to fix, potentially even undesirable to do so since it would require keeping things alive across the restart.
I'm going to move this back over to the EM. I'd like to remove the need for a restart (perhaps managing teardown) during startup which isn't really an EM bug though it affects the EM and other components like OS Integration. I'm going to discuss this with bsmedberg when he's here next.
Component: Installer: XPInstall Engine → Extension/Theme Manager
Product: Core → Firefox
QA Contact: xpi-engine → extension.manager
Duplicate of this bug: 405349

Comment 8

11 years ago
Maybe related to this bug see also
https://bugzilla.mozilla.org/show_bug.cgi?id=339804#c23
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
Depends on: 464461
So this should hopefully be fixed by bug 576553.
Depends on: 576553
(In reply to comment #9)
> So this should hopefully be fixed by bug 576553.

Dave, shouldn't this bug be fixed now?
Yes, fixed by bug 576553, not sure we have a way to test proxy auth right now though so a manual test would be required
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(In reply to comment #11)
> Yes, fixed by bug 576553, not sure we have a way to test proxy auth right now
> though so a manual test would be required

Even a manual test wouldn't be that easy. We do not have a solution yet to setup a proxy with auth. Lets see how we can make progress on it next year. Does it mean to be absolutely in-testsuite-?
Flags: in-testsuite?
Flags: in-litmus?
OS: Windows XP → All
Hardware: x86 → All
Target Milestone: --- → mozilla2.0b2
Given that we've moved downloading the updates to during runtime rather than at startup the chances of us regressing this is extremely slim so it is probably not worth tracking this for testing purposes.
Flags: in-testsuite?
Flags: in-testsuite-
Flags: in-litmus?
Flags: in-litmus-
I think we can safely mark it as verified fixed. Without the application restart for extension updates we don't have this problem anymore.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.