absolutely positioned element disappears

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
P4
normal
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Martin Kliehm, Assigned: Kevin McCluskey (gone))

Tracking

({dom2, helpwanted})

Trunk
Future
x86
Windows NT
dom2, helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I got 3 nested layers like in this example:

<DIV id="layer1Div"></DIV>
<DIV id="layer2Div">
    <DIV id="layer3Div"></DIV>
</DIV>

Now move layer3 around so that the width and height of layer2 is extended.
Changing the top position doesn't have any effect on layer1, but as soon as the
right margin of layer3 hits layer1's right margin, layer1 disappears.

Actually the problem is rather complex: layer2 has a width and height of 100px,
but no clipping. What should happen is either:

- setting layer3 inside layer2 should adjust layer2's width and height, so
layer2's blue background should grow while changing layer3's position.

or

- layer2's width and height should limit the visibility of layer3, so a clipping
would occur (but then again clip is set to "0px,0px,0px,0px", which contradicts
that?)

but what's happening is:

- layer2's width is adjusted, but not the height, and the background color stays
white, not transparent or blue.

Never mind the two external .js-files, they just take an OOP approach to
changing top and left positions. The result is the same, even when I position
the layers using plain CSS2, not DHTML.
(Reporter)

Comment 1

18 years ago
playing around with layer1 the aforementioned effect is also true for height...

Comment 2

18 years ago
what build are you using? please try againwith a new build
(Reporter)

Comment 3

18 years ago
The bug is still there. I just downloaded the latest nightly build (M16, 
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m16) Gecko/20000606). I also uploaded 
the testsuite again (sorry, my ISP lost the server so it was unavailable for a 
while).

The issue with nested layers has been resolved: The green nested layer is only 
visible within the blue parent layer.

But there's still the problem when moving the green nested layer. It isn't 
visible anymore since it is not within the blue parent layer, that's correct. 
But still the red layer disappears as soon as the green (invisible outside it's 
parent) layer is moved across.

Please note I can be reached under this e-mail address only until 14 June, use 
martin@bembelterror.de after this date.
Reflow problem, it seems.
Assignee: jst → buster

Comment 5

18 years ago
setting to NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

18 years ago
Kevin: I won't get to this before I go.  Can you take a look, and at least 
narrow it down a bit?  DBaron: a simpler test case would be a big help.
Assignee: buster → kmcclusk
Keywords: helpwanted

Comment 7

18 years ago
I'll try to hack out a testcase for this.

buster - you didn't cc dbaron. what's his email addr now, isn't he w/ nscp?
Keywords: makingtest
Summary: layer disappears → absolutely positioned element disappears
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Assignee)

Comment 8

18 years ago
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration. 
  
  
Target Milestone: M18 → Future
Keywords: dom2
Component: DOM Level 2 → DOM HTML
(Assignee)

Comment 9

16 years ago
Build moving all existing future-P3 bugs to future-P4.
Priority: P3 → P4

Comment 10

15 years ago
After revisiting my old bugs, it worksforme with Mozilla 1.4 (I've been the
original reporter). The inner green cube doesn't have any effect on the outer
blue cube anymore, just as expected. Could somebody please mark this bug as
resolved?

Comment 11

15 years ago
After revisiting my old bugs, it worksforme with Mozilla 1.4 (I've been the
original reporter). The inner green cube doesn't have any effect on the outer
blue cube anymore, just as expected. Could somebody please mark this bug as
resolved?

Comment 12

14 years ago
seems to WFM with 2004020311/win2k. resolving WFM per reporter's(?) latest comment.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: vidur → general
You need to log in before you can comment on or make changes to this bug.