Adding manually new bookmark is impossible unless protocol is specified

VERIFIED DUPLICATE of bug 385273

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 385273
11 years ago
8 years ago

People

(Reporter: Emil Ivanov, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

The button "Add" for adding new bookmark is unavailable until i type in the location field at least one letter with ":" ( example w: or http: ).

There is no indication that the protocol is required, the button just dont show up if the url is not ok.

If the bookmark is with protocol in the url, but without name it could be added and it shows in the boomarks menu without title while in Bookmarks Manager is with "(no title)".

I think it should be unavailable if the name and the location fields are both empty.

Reproducible: Always

Steps to Reproduce:
1.Open Bookmarks Manager
2.Select File > New Bookmark
3.Type in Location www.sitename.com
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
Confirmed on latest trunk: 
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007080309 Minefield/3.0a8pre ID:2007080309

Comment 2

11 years ago
Confirmed with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/2007080304 Minefield/3.0a7pre
OS: Windows XP → All

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 385273

Updated

11 years ago
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.