Last Comment Bug 390859 - AJAX site does not work properly, works in IE
: AJAX site does not work properly, works in IE
Status: RESOLVED FIXED
fixed by 383682
: fixed1.8.1.13, regression
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Blake Kaplan (:mrbkap)
:
:
Mentors:
http://devnet.backbase.com/demos/travel/
: 396113 (view as bug list)
Depends on:
Blocks: 382509
  Show dependency treegraph
 
Reported: 2007-08-03 13:33 PDT by Anthony Hughes (:ashughes) [GFX][QA][Mentor]
Modified: 2008-03-14 23:15 PDT (History)
11 users (show)
chung808: blocking1.9?
dveditz: blocking1.8.1.13+
mozillamarcia.knous: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Backbase screenshot (182.97 KB, image/png)
2007-09-13 00:57 PDT, Tony Chung [:tchung]
no flags Details

Description User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2007-08-03 13:33:11 PDT
This bug is from the following litmus test case: http://litmus.mozilla.org/show_test.cgi?id=4408
It occurs using GPa7rc1 on all platforms but works using FF2006 and IE7.

The problem is that navigating to the site, the application loads but the "application loading" dialog does not disappear.  You can click on flights, and it will add the total, but the flights do not move from the flight list to the shopping cart.

Steps to reproduce:
1. Navigate to provided url
2. Wait for all content to be displayed
3. Click on a "select" link

Actual results:
The "application loading" dialog remains on the screen and the cost of the selected flight is added to the total.  The flight is not removed from the available flights list, nor is it added to the shopping cart.

Expected results:
The "application loading" dialog should disappear after the application is loaded and flights should be moved from the available flights list to the shopping cart when selected.

This appears to be a regression.  I will work on finding a regression window as soon as testday is over, unless someone else wants to take this on.
Comment 1 User image Adam Guthrie 2007-08-03 16:28:24 PDT
I really hate testcases like this because a) site can change and b) this failing is not necessarily an indication that XMLHTTPRequest isn't working properly.
Comment 2 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2007-08-03 19:00:55 PDT
This regressed on 2007060504.

2007060504 -> Backbase site fails.
2007060405 -> Backbase works as it should.
Comment 4 User image Tony Chung [:tchung] 2007-09-13 00:57:28 PDT
I can repro this on minefield trunk nightly (M8).  This works fine on 2.0.0.6.  Can we get this fixed?

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; es-ES; rv:1.9a8pre) Gecko/2007091204 Minefield/3.0a8pre

Screenshot attached.
Comment 5 User image Tony Chung [:tchung] 2007-09-13 00:57:57 PDT
Created attachment 280713 [details]
Backbase screenshot
Comment 6 User image Carsten Book [:Tomcat] 2007-09-13 17:56:26 PDT
*** Bug 396113 has been marked as a duplicate of this bug. ***
Comment 7 User image Martijn Wargers [:mwargers] 2007-09-14 04:14:11 PDT
This might very well be a regression of bug 382509 (I think it's likely)
I saw this line in this.eval(a$); in the bpc_02.js file (wrapped in a try..catch block, so no errors are caught) (this is from http://devnet.backbase.com/demos/pim/ ).
Comment 8 User image Marcia Knous [:marcia - use ni] 2007-09-14 09:43:02 PDT
ispiked: I am all ears if you have suggestions on a better way to test this. Right now this is all we have from a manual test case standpoint.

(In reply to comment #1)
> I really hate testcases like this because a) site can change and b) this
> failing is not necessarily an indication that XMLHTTPRequest isn't working
> properly.
> 

Comment 9 User image Martijn Wargers [:mwargers] 2007-09-14 14:48:53 PDT
Well, the site in question uses all kinds of code, so by visiting that site and comparing the behavior on branch, you're a lot.
So I think it's useful to test these sites full of javascript stuff, only disadvantage is that it's hard to deduce what has regressed when something has stopped working. 
Comment 10 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2007-09-15 09:02:13 PDT
(In reply to comment #8)
> ispiked: I am all ears if you have suggestions on a better way to test this.
> Right now this is all we have from a manual test case standpoint.
> 
> (In reply to comment #1)
> > I really hate testcases like this because a) site can change and b) this
> > failing is not necessarily an indication that XMLHTTPRequest isn't working
> > properly.
> > 
> 

Perhaps we can create a staging area for our own test cases based on these sites that we use for test cases currently.  On the other hand, but using real world sites, it gives us real world results.  Perhaps this should be discussed at the next QA Execution meeting?
Comment 11 User image Blake Kaplan (:mrbkap) 2007-10-08 16:48:32 PDT
The patch in bug 383682 fixes this for me.
Comment 12 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2007-10-08 18:55:57 PDT
(In reply to comment #11)
> The patch in bug 383682 fixes this for me.
> 

I am assuming that this patch will go into tonights nightly.  If this is the case, I will check if this is fixed tomorrow.
Comment 13 User image Reed Loden [:reed] (use needinfo?) 2007-10-08 18:58:46 PDT
(In reply to comment #12)
> I am assuming that this patch will go into tonights nightly.  If this is the
> case, I will check if this is fixed tomorrow.

Still needs review and approval1.9 first before mrbkap can check-in the fix. Maybe brendan can get to it soon.
Comment 14 User image Blake Kaplan (:mrbkap) 2007-10-08 19:06:05 PDT
Well, it only needs approval at this point. One review is sufficient for js/src.
Comment 15 User image Martijn Wargers [:mwargers] 2007-10-23 10:24:53 PDT
Is this still an issue in current trunk build?
Comment 16 User image Blake Kaplan (:mrbkap) 2007-10-23 14:59:03 PDT
I can't reproduce anymore. Marking fixed as a result of bug 383682.
Comment 17 User image Samuel Sidler (old account; do not CC) 2008-03-07 10:28:28 PST
Fixed on the branch in bug 382509.
Comment 18 User image Al Billings [:abillings] 2008-03-14 17:07:20 PDT
The original test site doesn't exist anymore (it redirects to the root site). I see no issues on http://devnet.backbase.com/demos/pim/ with 2.0.0.12 so I can't reproduce the original bug.
Comment 19 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2008-03-14 18:29:02 PDT
The original URL was extracted from the litmus test cases.  If this site no longer exists and we have a new URL to test from, the testcase should be updated to reflect this.
Comment 20 User image Al Billings [:abillings] 2008-03-14 20:14:18 PDT
A new url is what I'm seeking. I don't understand the bug since the title is pretty vague.
Comment 21 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2008-03-14 20:32:35 PDT
Read the original description; it is much more descriptive.  Feel free to update the summary if you can find a better wording.  
Comment 22 User image Al Billings [:abillings] 2008-03-14 23:15:03 PDT
Yes, I read the description. That isn't the point. Without a site to repro the issue, it doesn't matter what the title says. We're not going to be able to verify that it is fixed since the root issue was never nailed down in any of the discussion here and it was fixed by the checkin for another bug.

Note You need to log in before you can comment on or make changes to this bug.