If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unknown protocol type set to always open in firefox.exe causes loop

REOPENED
Unassigned

Status

()

Firefox
File Handling
REOPENED
10 years ago
10 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
Note:  the included URL may look like it has a typo, but it is not.  See testcase http://litmus.mozilla.org/show_test.cgi?id=4407

Pasting this URL into GPa7rc1 causes a prompt to pop up asking for the user to choose an application for the file type.  If the user selects to open with firefox.exe and selects to remember this selection, it causes a loop of firefox trying to open this URL in new tabs.

Steps to reproduce:
1. Copy and paste the URL into the location bar, press enter or click the green arrow
2. When prompted to choose an application, browse to where GPa7rc1 is installed and select firefox.exe
3. Check the box to remember that selection
4. Click ok

Actual results:
GPa7 will try to continually open that link in consecutive new tabs until the process is halted

Expected results:
Based on logic, I would expect this to be the result.  Something should be done to prevent this from happening.

I will work on a regression range for this after test day.

Updated

10 years ago

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 369052
Not so sure it's a dupe - this is protocol handling, whereas that bug is content handling...

Updated

10 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

10 years ago
This is a regression to 2007073105.

2007073105 -> Choose Application dialog
2007073005 -> Error: Firefox doesnt know how to open specified protocol
You need to log in before you can comment on or make changes to this bug.