Closed Bug 390874 Opened 14 years ago Closed 14 years ago

gfxAtsuiFontGroup::InitTextRun is slow (in ATSUMatchFontsToText)

Categories

(Core :: Graphics, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 396732

People

(Reporter: sharparrow1, Unassigned)

Details

In a tp2 profile, ATSUMatchFontsToText is taking up a huge amount of time (25-30% of the total time in one profile).  The amount of time used seems excessive, even accepting that tp2 triggers fallbacks a lot more than normal pages.
While bug 396732 is more focused on binary-as-text, the root cause is the same as this, we're spending a lot of time doing font matching via ATSUMatchFontsToText.  The plan is to fix this by porting over the Windows font matching code, bug 396137.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 396732
You need to log in before you can comment on or make changes to this bug.