Closed Bug 390922 Opened 13 years ago Closed 11 years ago

File | Exit menu item in Event dialog is misleading and should be removed

Categories

(Calendar :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: theman_mtl, Assigned: maxxmozilla)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: 20070728

**********************************************************
*** This problem exist since a little while            ***
*** I just never open a Trouble Ticket for this        ***
**********************************************************

Subject: Inappropriate EXIT

OS: Windows XP : English
Thunderbird version: French 2.0.0.6
Extension:
     Lightning: 0.5 - English (Build: 2007062705)




To get back to the email, I have to restart thunderbird because, the application has been closed. 



Reproducible: Always

Steps to Reproduce:

When we are in the Calendar and we create a new Event or in the Address Book and we selected "Exit / Quitter" to quit the function and getting back to the email window, we quit the entire application. 

Scenario 1:
     Open the Address book
     Add a new contact
     Choose: Fichier (File) / Quitter (Exit)
     Result: Quit the address book and as well thunderbird where it's not good
     Therefore: If I’m closing the application by using the “X” in the Top Right Corner, the application is close properly. 

Scenario 2:
     Open the Calendar
     Add a new Event
     Save the action
     Chose: File / Exit
     Result: Quit the address book and as well thunderbird where it's not good
     Therefore: If I’m closing the application by using the “X” in the Top Right Corner, the application is close properly.

Actual Results:  
We are quitting the Adresse Book or the Event Window and we also quit Thunderbird

Expected Results:  
We should just exit the Address Book or the Event Window Calendar function.
Component: General → Lightning Only
Product: Thunderbird → Calendar
QA Contact: general → lightning
I assume you are using the WCAP-enabled Lightning version? The default Lightning version doesn't offer this functionality. In the WCAP-enabled version use File->Close to just close the event dialog, use File->Exit to exit the application.

Otherwise this bug belongs to Thunderbird because the Adresse Book is not part of Lightning.
See also Thunderbird Bug 352668 and Bug 348834.
Updating summary to match Thunderbird Bug 352668 and Bug 348834. If Thunderbird decides to remove this menu items we might consider removing it too. Leaving UNCONFIRMED for now.

Until then use File -> Close Window instead of File -> Quit.
Component: Lightning Only → General
OS: Windows XP → All
QA Contact: lightning → general
Hardware: PC → All
Summary: Inappropriate EXIT → File | Quit menu item in Event dialog is misleading and should be removed
As of thunderbird 2.0.0.9 (20071115), with lightning 0.8pre (2008021018) and gdataprovider 0.4pre, this is still a problem.

Scenario 3:
     Open Thunderbird with Lightning 
     Add a new Event
     Chose: File / Exit
     Result: Quits the address book and as well thunderbird where it's not good
     Therefore: If I’m closing the application by using the “X” in the
Top Right Corner, the application is close properly.

The "Add new event" window is a dialog, and there should not be any way to quit the thunderbird application from within that dialog.  File -> Quit should be removed.  However, File -> Close does work, as does clicking the "X" of the window.

Duplicate of this bug: 427625
Duplicate of this bug: 408983
Summary: File | Quit menu item in Event dialog is misleading and should be removed → File | Exit menu item in Event dialog is misleading and should be removed
Fixed by Bug 352668
Assignee: nobody → firefox
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Checked in lightning and sunbird buzild 20081207 -> VERIFIED.
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.