Camino Partially Shuts Down After a While

RESOLVED INCOMPLETE

Status

Camino Graveyard
General
--
critical
RESOLVED INCOMPLETE
10 years ago
10 years ago

People

(Reporter: Daryl Kulak, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.4) Gecko/20070509 Camino/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.4) Gecko/20070509 Camino/1.5

Discussion has been occurring at this URL:

   http://forums.mozillazine.org/viewtopic.php?p=2998448#2998448


Seems like I'm not the only person this is happening to.

I'm having problems with Camino kind of losing functionality after going for a while.

It seems to lose the ability to create a new tab, click on a link, go to Home, etc.  Sometimes it will just load some of the images and stop.

However, I don't get the beachball and Camino otherwise seems to be operating. This only began happening since I moved to v1.5. I often use Google applications like Reader, Docs & Spreadsheets and iGoogle.

Do these apps cause problems for Camino? Or is there something in v1.5 that could possibly cause a partial shutdown like this?  Is it a caching problem?

I'm using Camino 1.5 on Mac OS X 10.4.10.


Reproducible: Sometimes

Steps to Reproduce:
1.  Use Camino for at least 30 minutes (varies for other people).
2.  Camino will stop working partially (can't set up a new tab, won't load images).
3.  You have to shut Camino down and start over.

Actual Results:  
Camino partially stops working, won't load --some-- images, won't load a stylesheet, won't allow me to create a new tab, won't go to a link.



Info from my console log (filtered for Camino):


2007-08-05 01:42:12.518 Camino[2083] Unable to set languages - language 'English' not a valid ISO language identifier
2007-08-05 11:04:08.928 Camino[2185] Unable to set languages - language 'English' not a valid ISO language identifier
2007-08-05 11:39:09.007 Camino[2185] CFLog (21): Cannot recognize type of executable for CFBundle/CFPlugIn 0x181a2b90 </Users/daryl/Library/Contextual Menu Items/icWordCM.plugin> (not loaded)
2007-08-05 11:39:09.007 Camino[2185] CFLog (22): Cannot find function pointer AbstractCMPluginFactory for factory 7DEDA736-0F3D-11D6-BC12-00050289EC9F in CFBundle/CFPlugIn 0x181a2b90 </Users/daryl/Library/Contextual Menu Items/icWordCM.plugin> (not loaded)



I consider this a crash.

Comment 1

10 years ago
Does that console log span a period of time where you were experiencing the problems you described?

Please run the following command in Terminal while Camino is running, and
attach the resulting camino_mapped_libraries.txt file here using "Add an
attachment" above.
vmmap Camino -w | grep __DATA > camino_mapped_libraries.txt
(Reporter)

Comment 2

10 years ago
Yes, I had the problem during the timespan of this log (today's entries).

I'll attach the file you mentioned as well.

Thank you so much for your help.
(Reporter)

Comment 3

10 years ago
Created attachment 275338 [details]
Camino Mapped Libraries (for help with debugging)

Attached in response to a request (see discussion).

Comment 4

10 years ago
You are running the following system-modifying components:

/Library/Application Enhancers/LCC Scroll Enhancer.ape/Contents/MacOS/LCC Scroll Enhancer
/Library/InputManagers/Ecamm/Ecamm Plugin Loader.bundle/Contents/MacOS/Ecamm Plugin Loader
/Library/Frameworks/ApplicationEnhancer.framework/Versions/A/ApplicationEnhancer

Please try to reproduce this problem without any of them installed/running (and in the future, please don't file bugs until you can reproduce them on a system that isn't running unsupported system hacks).
(Reporter)

Comment 5

10 years ago
I know what Ecamm is (it records Skype calls), but I have no idea what these other things are.  I'll try to look into it, but I don't know how I'll avoid filing a bug in the future without checking things that I have no idea exist on my system.
(Reporter)

Comment 6

10 years ago
Instructions for uninstalling Ecamm were here:

          http://www.ecamm.com/mac/callrecorder/faq.html


Instructions for uninstalling ApplicationEnhancer (from Unsanity):

          http://softwaretrenches.com/2006/08/removing_unsanitys_application.html


I couldn't find instructions on how to uninstall LCC Scroll Enhancer, so I just deleted that folder from /Library/Application Enhancers.

I have to reboot to see what happens.  I'll post another entry then.
(Reporter)

Comment 7

10 years ago
It is still happening, even after deleting the system-modifying components.

Log of camino_mapped_libraries is attached.
(Reporter)

Comment 8

10 years ago
Created attachment 275416 [details]
A second log of Camino activity after removing app enhancers

Comment 9

10 years ago
Is that icWord contextual menu plugin a total red herring, or might that be involved somehow?
(Reporter)

Comment 10

10 years ago
I can't find any reference to icWord in the mapped libraries file.  Where did you see it, Chris?

Comment 11

10 years ago
(In reply to comment #9)
> Is that icWord contextual menu plugin a total red herring

It's not loaded, so it's hard to imagine how it could be the problem.
(Reporter)

Comment 12

10 years ago
After removing all those "application enhancers" the problem still occurs.  One thing that seems to be related (I can't say everytime, but...) is when I click a link that wants to open another browser window.  I have Camino set to usually open a new page in another tab, but sometimes I think the html code overrides that to open a new browser window on the desktop.  I have noticed a few times (but I don't think every time) that this will cause the problem to occur (see first post).

Thanks again for contributing ideas.  I hate to say it, but I am so close to shutting down Camino for good and switching to Firefox or Safari.  I really don't want to do that.

Comment 13

10 years ago
One other data point that would be useful would be to get it into this state, try to open a new window, and see if that logs to the console. That should tell us whether this is actually the same "Camino becomes half-dead" bug that others are seeing that appears to be an app-wide I/O problem (I was assuming it was different since there was no logging about that, but reading the report again it's not clear whether opening a new window in this state was ever tried).
(Reporter)

Comment 14

10 years ago
Unfortunately I've had to move to Safari because this problem was crippling my work.  Sorry but I can't be much help anymore.  I will close this bug.  Yes, it sounds like it might be similar to the other bug you mentioned.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Not FIXED.
Resolution: FIXED → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.