automatic update to 2.0.0.6 gets offered for installation, gets accepted, fails to install without notification

VERIFIED INCOMPLETE

Status

()

Toolkit
Application Update
--
major
VERIFIED INCOMPLETE
11 years ago
9 years ago

People

(Reporter: WernerU, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Firefox/2.0.0.6

I reported yesterday that since 2.0.0.6 became available, the auto-update process suggested to update to 2.0.0.6 (from 2.0.0.5) every day -- which I accepted/allowed (running in the admin account), and whereas it seemed to download and install alright (no failure notification, it offered to restart Firefox), it must have failed because the next day the same would happen again (and checking the version number indicated I was running 2.0.0.5 still).  Today I downloaded and saved the updator as a file, quit Firefox, disconnected from the net, and executed the updator -- which led to the following error messages (see Actual Results) after which I rebooted my machine and executed the updator again, this time without a problem.


Reproducible: Always

Steps to Reproduce:
strangely enough, the install.log didn't show the update attempt had taken place (it should).  also, when I just tried to check that out again, I notice that the install.log now only contains information about the (now) successful installation of 2.0.0.6, i.e. didn't keep the previous file(s) (that's BAD!  all logs should be kept on computers nowadays that memory space is cheap)

Actual Results:  

[first pop-up window titled] Mozilla Firefox Setup
Installing
  Please wait while Mozilla Firefox is being installed

  A Little Housekeeping...
   ||


[new window titled] Mozilla Firefox Setup
(?)  Error opening file for writing:
C:\Program Files\Mozilla Firefox\firefox.exe
Click Retry to try again, or
Cancel to stop the installation



Expected Results:  
notified me that the update installation didn't succeed, and an indication why.

I wished a copy of my bug-report would be emailed TO ME auto-magically also.
I hate such web-form data entries where the person entering the data is left without date-time-stamped records of what was said/written...
(Reporter)

Comment 1

11 years ago
Additional Comment:
the Version field contained the specific description of the now running 2.0.0.6 version.  I modified it trying to indicate that it was the 2.0.0.5 version that was running when I experienced the problem...  but I no longer had those specifics available.  then was unable to get the 2.0.0.6 info to reappear in the Version field...  NOW I see it say "Unspecified" so I changed it choosing (from among what's offered/available) the "2.0 Branch" (whatever that may mean).  sorry that's messed up that way.

and now that I'm on this "Additional Comments" phase I see below now an option to "Add me to a CC list".  this sounds more than just sending a copy of my report to me (as if I might get copied in all traffic that my bug report leads to); I wouldn't want that, don't think I could contribute (requests for clarification I'd welcome and answer, of course).  Also, at this point I thought I'd best remove my remark about wishing for a CC-copy... but there seems no way to edit/remove that anymore -- or am I overlooking something, some <edit> button somewhere?
Version: unspecified → 2.0 Branch

Comment 2

11 years ago
If you have the original "updater" file (which is actually the normal installer), you can always remove the application first (using Control Panel -> Add or Remove Programs), then install it manually again. This will delete any problems that you might have, and perform a clean install. This is normally not necessarily (you can safely install over an older version), but since you reported problems, I would consider to perform such a clean install anyway.

Please make sure that Firefox is not running when you delete and install, as this seem to have been a problem during your install. Normally, you get a warning before you start the install, but it didn't work for one or another reason.

Your data (preferences, bookmarks, etc ...) will be fine, it's not stored in C:\Program Files


And about the cc-report, don't worry. You'll receive all comments that are added to the bug-report (like this one). I'm not sure why it got offered again, you're automatically on the list ofcourse.

Comment 3

11 years ago
Just one more user experiencing the same day to day repetition.  One additional note though is that this only appears to be happening on my XP machine at work, not on my Vista machine at home.  Home machine is new though (less than one week). So the first download may have been Firefox 2.0.0.6.
Are you using any antispyware/antivirus software=
it is known to happen with application like SpybotS&D TeaTimer, so check if you have that running oi backgroud, something is locking your firefox.exe file
Component: Startup and Profile System → Software Update
QA Contact: startup → software.update

Comment 5

11 years ago
SpybotS&D Teatimer was the problem with comment#3.  Just disabled teatimer and started update.  2.0.0.6 installed successfully.  Thanks for your help Marco.
thank you
marking invalid -> problem caused by a third party software
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

11 years ago
while it may be correct that the problem is/was caused by an *interaction* with third party software (I can't confirm it as I managed to arm-wrestle 2.0.0.6 to install after all -- reread my story again, please), I disagree that there is no problem to fix (or whatever INVALID is supposed to mean)

First, until the 2.0.0.5 to 2.0.0.6 update, there was no conflict with Tea-Timer apparently.  So the least to do is to contact "those people" and discuss the problem and cooperate to analyze and resolve it.  I mean, it is not unheard of that such interaction problems kick up when "the other fellow" narrows down an algorithm to be dealing some data-structures in a *more formally correct manner*.  So until it is certain who/what is causing this why, I disagree to simply let matters continue this way, leave users to get puzzled and frustrated over this happening, without the FireFox team 'becoming part of the solution' (as one might want to describe it).  It's not necessarily so much about 'who is at fault, who is causing it' but rather 'this causes our users problems and we need to see such things addressed!'

Second, I reported that the process of allowing a download and auto-install *appeared* to work as always (complete successfully)... only to get invited again the next day to update.  In my opinion, (a) there should be a completion (or failure to install) message at the time of the (supposed) update.  (b) the next day, the installation process should be able to recognize (somehow) that an update attempt had been made already, that had failed (somehow), and the user should be accordingly notified.  (c) the logfiles should keep a record of this sequence of events having happened, and not be overwritten (or whatever happened for that log to disappear)

Third, something I had not mentioned before (as it became clear only later).  After my *manual* installation (as described previously) I later on, after reporting about it here, decided to throw the installer file into the trash.  Well, the system wouldn't allow me to do that, reporting that the file "was used by someone/somehow" (or words to that effect.  Given that I had executed the installer by double-clicking it and it finished without any problem getting reported to me, I found that odd -- and if it is the Spybot/Teatimer causing this, it sure is a new behavior (maybe there was a TeaTimer auto-update, though I don't think there is such a thing) but *someone* (it or the FireFox updating process) should have been giving me a heads-up about it.
Resolution: INVALID → INCOMPLETE
Sorry about that, but is plenty of antivirus/spyware software that do scanning without blocking anything, while teatimer is largely known to cause such a problem... That is because in my opinion there is a problem on their side. 
I agree with you that FF should notify the user someway about those kind of problem, and i'm pretty sure that the dev team has noticed that.
Try to contact spybot dev team about this problem, if they can point you to a Firefox bug/problem reopen this report and post new informations based on that.

Also, about your third problem. you should try to discover who is using that file, try to disable antivirus and antispyware one by one, to find where is the problem. I'm reopening this waiting for updtades from your tests.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 9

11 years ago
This problem is highly likely to be creating significant loading on Firefox's patch download system plus substantial and widespread (& unnecessary) negative customer experience (breach of trust / denigration of Mozilla dev's image).  

Firefox -> About -> Help shows that I'm on 2.0.0.6 and yet auto-update keeps trying to re-download and update me to it.  

PC, XP.  No teatimer and spyware protection disabled. 

10x cycles... 

Comment 10

11 years ago
PS I'm aware that I can uninstall, re-install and the _symptom_ will probably go away. I'm also aware that if it happens to many system then we should find out exactly how and remove that path.  We should be setting an "update-in-progress" flag (if it doesn't exist) when we start update, clear it when we finish the process, and raise the count when we reboot and find the flag still exists.  If count >= 3 then STOP and give request uninstall, reinstall msg... 

Here's my cycle: 

Problem: 2.0.0.6 update continually reapplies itself in two complete download cycles - then starts the cycle all over and fails to find the Update Server: 

Here are the steps:

((( 0) Help - About: 2.0.0.6 )))

1) Help - 2) Check for Update: 

3) Update Available: Firefox 2.0.0.6 - Strongly recommended. 

4) Download & Install Now... 

5) Downloading the update ...  scan  

6) Downloading Firefox 2.0.0.6..  xx of 7.3MB    <<< # 1 >>>

7) Update Downloaded - 
	Successfully downloaded and verified & will be installed next time Firefox starts. 

8) Restart Firefox Now

9) Update failed - The partial Update could not be applied. Firefox will try again by downloading a complete 

Update. 

10) Next

11) Downloading Firefox 2.0.0.6 - xx of 7.3MB   <<< # 2 >>>

12) Update Downloaded. 
	Successfully downloaded and verified & will be installed next time Firefox starts. 

13) Restart Firefox Now

14) Update Available...  (Step # 1 again...)

15) This time it just continues to scan the Update Server: 
	Connecting to Update Server...


---

Over the last month I've gone through the whole 2.0.0.6 update cycle several times (to see if it had gotten fixed yet).  (I can uninstall / re-install, but that's not the point - update system loading & customer experience... )


Do you know that you have a problem? 
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Comment 11

9 years ago
stillsee this problem?
Whiteboard: closeme 2009-06-15
Closing via comments in whiteboard to close after 6-15-09 if no update given by then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago9 years ago
Resolution: --- → INCOMPLETE
Whiteboard: closeme 2009-06-15
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.