Would like to be able to delete a user-added toolbar permanently

RESOLVED INVALID

Status

()

--
enhancement
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: sicesp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

The toolbar customization menu has a button for "Add New Toolbar".  If you use this feature and then later decide to get rid of the new toolbar, it would be nice to easily and intuitively be able to do this, without having to restore all toolbars to defaults.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
The custom toolbar can be removed by removing all the items on it. Not exactly intuitive but you don't have to reset all the toolbars.

Duplicate of bug 212990.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 212990
(Reporter)

Comment 2

11 years ago
No, toolbar has NO ITEMS on it whatsoever.  The problem is still there.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Most likely there is a 'spacer' or flexbox on the bar else it would go away.  Spacers and flexbox's are hard to see on the bar as they are not highlighted to make removal easier.  Drag your mouse slowly from one end of the bar to the other and you most likely will discover the problem, drag it off the bar and the bar will go away.

(Reporter)

Comment 4

11 years ago
I appreciate all of these comments.  However I have no spacer that I can either see in the toolbar or find by dragging the mouse to the edges.

No matter how much I try to find a "hidden" item on the toolbar, there isn't one, and the toolbar WILL NOT go away.

(i.e. I am not reporting a UFO with little green men inside.)
(Reporter)

Comment 5

11 years ago
Correction:  I am reporting a UFO with little green men inside.

The situation appears that the spacers can only be accessed while the customization menu is displayed.  If not displayed, spacers are neither shown, nor are accessible via the mouse.  I was able to remove the spacers ONLY with the menu displayed.  But FF only lets me shift them to another toolbar; eventually this could lead to being forced to revert to defaults due to "leak" of toolbar items.

Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
Summary: Would like to be abel to delete a user-added toolbar permanently → Would like to be able to delete a user-added toolbar permanently
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.