Closed Bug 391096 Opened 13 years ago Closed 13 years ago

/usr/bin/ld: warning can't open dynamic library: @executable_path/libmozlcms.dylib referenced from: ../../dist/bin/libthebes.dylib

Categories

(Firefox Build System :: General, defect)

PowerPC
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9alpha8

People

(Reporter: mats, Assigned: mats)

References

Details

Attachments

(2 files, 1 obsolete file)

Firefox build fails on MacOSX with:

ac_add_options --enable-debug
ac_add_options --enable-accessibility
ac_add_options --disable-libxul
ac_add_options --disable-airbag

It fails when linking libaccessibility.dylib:

nsAccessibilityFactory.cpp
c++ -o nsAccessibilityFactory.o -c -I../../dist/include/system_wrappers -include ../../config/gcc_hidden.h -DMOZILLA_INTERNAL_API -DOSTYPE=\"Darwin8.10.1\" -DOSARCH=Darwin
-I./../src -I../../dist/include/xpcom -I../../dist/include   -I../../dist/include/accessibility -I../../dist/include/nspr  -DMOZ_PNG_READ -DMOZ_PNG_WRITE   -I../../dist/sdk
/include    -fPIC   -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno
-long-long -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fpascal-strings -no-cpp-precomp -fno-common -fshort-wchar -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarb
on -pipe  -DDEBUG -D_DEBUG -DDEBUG_mats -DTRACING -g   -DMOZILLA_CLIENT -include ../../mozilla-config.h -Wp,-MD,.deps/nsAccessibilityFactory.pp nsAccessibilityFactory.cpp
rm -f libaccessibility.dylib
c++  -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -isy
sroot /Developer/SDKs/MacOSX10.4u.sdk -fpascal-strings -no-cpp-precomp -fno-common -fshort-wchar -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon -pipe  -DDEB
UG -D_DEBUG -DDEBUG_mats -DTRACING -g -fPIC  -o libaccessibility.dylib  nsAccessibilityFactory.o  nsAccessNode.o nsAccessibleEventData.o nsARIAMap.o nsDocAccessible.o nsOut
erDocAccessible.o nsAccessibilityAtoms.o nsAccessibilityUtils.o nsAccessibilityService.o nsAccessible.o nsAccessibleRelation.o nsAccessibleTreeWalker.o nsBaseWidgetAccessib
le.o nsFormControlAccessible.o nsRootAccessible.o nsApplicationAccessible.o nsCaretAccessible.o nsTextAccessible.o nsHTMLAreaAccessible.o nsHTMLFormControlAccessible.o nsHT
MLImageAccessible.o nsHTMLLinkAccessible.o nsHTMLSelectAccessible.o nsHTMLTableAccessible.o nsHTMLTextAccessible.o nsHyperTextAccessible.o nsAccessNodeWrap.o nsRootAccessib
leWrap.o nsAccessibleWrap.o mozAccessible.o mozDocAccessible.o mozActionElements.o mozTextAccessible.o nsXULAlertAccessible.o nsXULColorPickerAccessible.o nsXULFormControlA
ccessible.o nsXULMenuAccessible.o nsXULSelectAccessible.o nsXULSliderAccessible.o nsXULTabAccessible.o nsXULTextAccessible.o nsXULTreeAccessible.o nsXFormsAccessible.o nsXF
ormsFormControlsAccessible.o nsXFormsWidgetsAccessible.o           -L../../dist/bin -L../../dist/lib -lgkgfx -lthebes ../../dist/lib/libunicharutil_s.a -L../../dist/bin -lx
pcom -lxpcom_core -L../../dist/bin -L../../dist/lib -lplds4 -lplc4 -lnspr4  -framework Cocoa  -bundle
/usr/bin/ld: warning can't open dynamic library: @executable_path/libmozz.dylib referenced from: ../../dist/bin/libthebes.dylib (checking for undefined symbols may be affec
ted) (No such file or directory, errno = 2)
/usr/bin/ld: warning can't open dynamic library: @executable_path/libmozlcms.dylib referenced from: ../../dist/bin/libthebes.dylib (checking for undefined symbols may be af
fected) (No such file or directory, errno = 2)
/usr/bin/ld: Undefined symbols:
_cmsDoTransform referenced from libthebes expected to be defined in @executable_path/libmozlcms.dylib
_cmsCreateTransform referenced from libthebes expected to be defined in @executable_path/libmozlcms.dylib
_cmsCreate_sRGBProfile referenced from libthebes expected to be defined in @executable_path/libmozlcms.dylib
_cmsErrorAction referenced from libthebes expected to be defined in @executable_path/libmozlcms.dylib
_cmsOpenProfileFromFile referenced from libthebes expected to be defined in @executable_path/libmozlcms.dylib
collect2: ld returned 1 exit status
make[5]: *** [libaccessibility.dylib] Error 1
make[5]: Leaving directory `/Users/mats/firefox/mozilla/accessible/build'
make[4]: *** [libs] Error 2
make[4]: Leaving directory `/Users/mats/firefox/mozilla/accessible'
Attached file .mozconfig
Attached patch Like so? (obsolete) — Splinter Review
Not sure if this is the right way, but it works...
Attachment #275518 - Flags: review?(benjamin)
Comment on attachment 275518 [details] [diff] [review]
Like so?

Not really. There's no need for accessibility to link against zlib/lcms directly. You want MOZ_FIX_LINK_PATHS
Attachment #275518 - Flags: review?(benjamin) → review-
Attached patch Better?Splinter Review
Attachment #275518 - Attachment is obsolete: true
Attachment #275994 - Flags: review?(benjamin)
Attachment #275994 - Flags: review?(benjamin) → review+
Attachment #275994 - Flags: approval1.9?
Assignee: nobody → mats.palmgren
Duplicate of this bug: 392390
FYI, there's another mac-a11y bustage after this patch. See bug 390154 for that patch.
Flags: blocking1.9?
Comment on attachment 275994 [details] [diff] [review]
Better?

a=bzbarsky
Attachment #275994 - Flags: approval1.9? → approval1.9+
I took the liberty to check this in for you Mats, since it's been hanging around for so long already (being a bustage and all). I hope that was OK.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Thanks!
Flags: blocking1.9?
Target Milestone: --- → mozilla1.9 M8
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.