<?xml?> element crashes browser

VERIFIED DUPLICATE of bug 27507

Status

()

Core
XML
P3
critical
VERIFIED DUPLICATE of bug 27507
18 years ago
18 years ago

People

(Reporter: gerv, Assigned: harishd)

Tracking

({crash, regression, testcase})

Trunk
x86
Windows 95
crash, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (Win95; U)
BuildID:    20000512

The testcase (a very simple bit of code) crashes the browser.

<?xml version="1.0" standalone="no" encoding="UTF-8"?>
<html>
<head>
</head>
<body>
</body>
</html>

This regressed between 20000509 and 20000511.

Gerv
Adding keywords, changing severity.

Gerv
Severity: normal → critical
Keywords: crash, regression, testcase
Created attachment 8602 [details]
test case (also in comments)

Comment 3

18 years ago
looks like a dup of bug 27507
Thanks, it is.

Gerv

*** This bug has been marked as a duplicate of 27507 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Reopening, as the bug this is marked a DUPE of is marked a DUPE of a FIXED bug, 
and this problem still occurs (and is blocking Bug 33605).

Gerv
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Duplicate of bug 39520?
CCing rickg@netscape.com, who will probably know what to do with this bug.

This is all too confusing...

Gerv

Comment 8

18 years ago
Harish, here's the call stack.  We use the HTML content sink with the XML DTD, 
which is probably why we crash:

SinkContext::CloseContainer(const nsIParserNode & {...}) line 1346 + 3 bytes
HTMLContentSink::CloseContainer(HTMLContentSink * const 0x03785ab0, const 
nsIParserNode & {...}) line 2927 + 18 bytes
CWellFormedDTD::HandleEndToken(CToken * 0x02e8cb90) line 662 + 31 bytes
CWellFormedDTD::HandleErrorToken(CToken * 0x03316ae0) line 709
CWellFormedDTD::HandleToken(CWellFormedDTD * const 0x03317920, CToken * 
0x03316ae0, nsIParser * 0x03787150) line 526 + 12 bytes
CWellFormedDTD::Terminate(nsIParser * 0x03787150) line 362 + 20 bytes
nsParser::Terminate() line 1091 + 33 bytes
nsParser::Tokenize(int 0) line 2055 + 11 bytes
nsParser::ResumeParse(int 1, int 0) line 1488 + 12 bytes
nsParser::OnDataAvailable(nsParser * const 0x03787158, nsIChannel * 0x03779400, 
nsISupports * 0x00000000, nsIInputStream * 0x03782044, unsigned int 0, unsigned 
int 99) line 1937 + 19 bytes
nsDocumentOpenInfo::OnDataAvailable(nsDocumentOpenInfo * const 0x03779130, 
nsIChannel * 0x03779400, nsISupports * 0x00000000, nsIInputStream * 0x03782044, 
unsigned int 0, unsigned int 99) line 210 + 46 bytes
nsHTTPFinalListener::OnDataAvailable(nsHTTPFinalListener * const 0x03778f60, 
nsIChannel * 0x03779400, nsISupports * 0x00000000, nsIInputStream * 0x03782044, 
unsigned int 0, unsigned int 99) line 1217 + 46 bytes
InterceptStreamListener::OnDataAvailable(InterceptStreamListener * const 
0x03782040, nsIChannel * 0x03779400, nsISupports * 0x00000000, nsIInputStream * 
0x03316bf0, unsigned int 0, unsigned int 99) line 1165
nsHTTPChunkConv::OnDataAvailable(nsHTTPChunkConv * const 0x02b37878, nsIChannel 
* 0x03779400, nsISupports * 0x00000000, nsIInputStream * 0x03782c5c, unsigned 
int 0, unsigned int 106) line 208 + 46 bytes
nsHTTPServerListener::OnDataAvailable(nsHTTPServerListener * const 0x03782ce0, 
nsIChannel * 0x0360b924, nsISupports * 0x03779400, nsIInputStream * 0x03782c5c, 
unsigned int 0, unsigned int 106) line 540 + 67 bytes
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x03780300) 
line 406 + 47 bytes
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x03781330) line 97 + 12 bytes
PL_HandleEvent(PLEvent * 0x03781330) line 575 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x0149f0c0) line 520 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x00710410, unsigned int 49355, unsigned int 0, 
long 21622976) line 1032 + 9 bytes
USER32! 77e71820()
0149f0c0()
Assignee: nisheeth → harishd
Status: REOPENED → NEW
(Assignee)

Comment 9

18 years ago

*** This bug has been marked as a duplicate of 27507 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 10

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.