A border-collapse table affects the layout (style data?) of a different table element

RESOLVED DUPLICATE of bug 186317

Status

()

RESOLVED DUPLICATE of bug 186317
11 years ago
9 years ago

People

(Reporter: terrafrost, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(6 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Compare the following two pages:

http://www.frostjedi.com/terra/scripts/demo/reversi/tables-collapse.html
http://www.frostjedi.com/terra/scripts/demo/reversi/tables-collapse2.html

Note the appearance of the second table on the first page in Firefox. The only difference between it and the first table is the border-collapse setting. Contrast this with the second page. Three tables, two border-collapse settings. The same two we saw on this page. Yet one of the border-collapse settings looks differently on that page then it does on this page.

In Internet Explorer, it's consistent for both pages.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

11 years ago
Component: General → Layout: Tables
Product: Firefox → Core
QA Contact: general → layout.tables
Version: unspecified → Trunk

Comment 1

11 years ago
Created attachment 280331 [details]
HTML to demonstrate the problem

I've experienced the same problems, but have also noticed that the presence or absence of heading and/or data cells in the first table affect how those in the third are displayed.  This attachment is a standalone file that can be viewed in four different ways to demonstrate the problem: just click each of the links and see how the third table changes.

Comment 2

11 years ago
Sorry, didn't realise the attachment wouldn't retain its filename: save it as tables.html and then open it.

Updated

10 years ago
Keywords: testcase

Comment 5

10 years ago
Created attachment 344058 [details]
Testcase #3a
Attachment #280331 - Attachment is obsolete: true

Comment 6

10 years ago
Created attachment 344059 [details]
Testcase #3b

Comment 7

10 years ago
Created attachment 344060 [details]
Testcase #3c

Comment 8

10 years ago
Created attachment 344061 [details]
Testcase #3d

Comment 9

10 years ago
Maybe related to bug 211636?
http://hg.mozilla.org/mozilla-central/file/30d9ff763b22/content/html/content/src/nsHTMLTableElement.cpp#l1117
Status: UNCONFIRMED → NEW
Depends on: 211636
Ever confirmed: true
Flags: in-testsuite?
OS: Windows XP → All
Hardware: PC → All
Summary: inconsistent border-collapse renderings → A border-collapse table affects the layout (style data?) of a different table element

Comment 10

10 years ago
is this bug a dupe of bug 186317

Comment 11

10 years ago
the code in comment 9 is already marked for removal see the patch for bug 43178, which is slowly moving trough review mills.

Comment 12

9 years ago
this is wfm due to the fix for bug 43178, I will check in a test case for bug 186317
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 186317
You need to log in before you can comment on or make changes to this bug.