Messages list pane left blank until "Get new messages" action

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: thib´, Assigned: Bienvenu)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla Thunderbird 2.0.0.6 (2007-07-28)

When setting "mail.password_protect_local_cache" to "true", the messages list pane is left blank even..
- after entering the correct password,
- if, of course, there already are messages stored locally.

After using the "Get new messages" function (for any or all account(s),) the list reappears normally (even if no message is downloaded.)


This bug appeared for the first time in the first release of Thunderbird 2, as it worked fine in every older versions.

Reproducible: Always

Steps to Reproduce:
1. Set a Master Password via "Tools > Options > Privacy > Passwords > Change Master Password",
2. Set "mail.password_protect_local_cache" to "true" in "prefs.js" file or via the "Config Editor" in "Tools > Options > Advanced > General > Config Editor",
3. Set all accounts not to check for new mails automatically at startup by unchecking the box "Check for new messages at startup" in "Tools > Account Settings > [Account Name] > Server Settings > Server Settings",
4. Restart Thunderbird,
5. Open any folder known not empty,
6. When prompted for the Master Password, enter the correct password defined just before.
Actual Results:  
The messages list pane remains blank as if the folder was empty.

Expected Results:  
The messages stored locally into the folder should be displayed.
In order to do so [temporary fix], check for new mails via "File > Get New Messages for > Get All New Messages".

Using ProfilePassword 0.7.5 Add-on by Kaosmos for weak protection instead (only Add-on installed, and -after- the bug appeared for the first time after updating Thunderbird to version 2.)
(Assignee)

Comment 1

11 years ago
are these imap or local/pop3 folders?

I believe we want the password for the incoming server corresponding to the folder, not the master password. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

11 years ago
We may prompt you for the master password in order to check that the per-server password is correct - I haven't tried this with a master password. In theory, it would be nice to just verify the master password, if the user has one, but I don't think that's what the code does, or has ever done, unless it changed w/o my knowing about it.
(Reporter)

Comment 3

11 years ago
Sorry, forgot to mention that clearly, it's about local/pop3 folders; thus we aren't even talking about per-server passwords since we just want the local messages list to show before even checking for new mails on any server. The only thing about Getting new messages is that it corrects the bug for the session (and I also forgot to mention that it's needed to switch to another directory once after checking the new messages for this trick to work.)

Thanks for you very-fast reply (I'm impressed ^^')
Keywords: clean-report
(Assignee)

Comment 4

11 years ago
Even for local/pop3 folders, we use the password for some server, the pop3 server if it's a pop3 account, and for the local folders account, probably the default server. We can't assume there is a master password, in general, so we need to find some server with a password. Is it possible that in 1.5 you were entering the server password?

This feature gets more testing with IMAP, so I'm not shocked it regressed. The reason getting new mail fixes the problem is that marks the server as "authenticated", so then we show you the local contents...
Assignee: nobody → bienvenu
(Reporter)

Comment 5

11 years ago
Oh, I didn't know about the "password selection", I thought it simply wouldn't work without Master Password; well, anyway I've always used MP, including in 1.5, and I clearly remember it worked just fine (just after entering the password, it showed it all in the pane without checking any account for new mails,) even if yes, it's actually "more" intended for IMAP. In fact, I guess it shouldn't work at all for local/pop3: I can see a tip named "Password protect the message pane (IMAP only)" @ http://www.mozilla.org/support/thunderbird/tips.

So, the bug maybe isn't one actually, or there'd better be some usage restrictions when applying this function using local/pop3 accounts. It's just weird it worked before, that was pretty handy (I know it's very weak, but it's without pretention.)

-----
Appart from that, I never used IMAP so I can't really tell but.. I don't understand the point of protecting some local stuff if you don't even download it.. or do you? Excuse me if it's another debate that shouldn't be but I'm a bit confused about how IMAP actually works.
Version: unspecified → 2.0
(Assignee)

Comment 6

11 years ago
For IMAP, the desire was to prevent a snoop from seeing the subjects and senders of messages (i.e., the message list), and if the messages were stored offline, the bodies of the messages.

The same thing is true for local messages, and we did intend this to work for local folders/pop3 accounts. It's just that it got more testing by imap users, I think.
(Reporter)

Comment 7

11 years ago
Okay, thank you for all !

Comment 8

9 years ago
thib, please check to see if this is gone, using most recent beta.
 http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
 backup your profile before using

Comment 9

9 years ago
I've never seent his and reporter email is unreachable
=> WFM
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.