I installed the theme and clicked on install multiple times, causing FX to crash

VERIFIED DUPLICATE of bug 259688

Status

()

VERIFIED DUPLICATE of bug 259688
11 years ago
10 years ago

People

(Reporter: iSafari.Themes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

I was going to install a new theme so I decided to try macfox. I clicked on the install button more then once (I think like 3) It installed slow, but, it crashed.

Reproducible: Always

Steps to Reproduce:
1. Uhm.... don't click install more then once
2. uhm.... repeat step 1
3. repeat step 2
Actual Results:  
FX didn't crash

Expected Results:  
Not Crashed

about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-official-branding --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-svg --enable-canvas --enable-update-packaging
At what point in the steps did the xpinstall dialog (the dialog with the countdown for confirming the install) display in the steps to reproduce? Was it displayed more than once? Did you confirm the install more than once?
(Reporter)

Comment 2

11 years ago
I click Install once. The message appeared more then once.
 I'm sorry but I don't understand your other question robert...
Created attachment 275733 [details]
XPInstall dialog screenshot

Your steps to reproduce
Steps to Reproduce:
1. Uhm.... don't click install more then once
2. uhm.... repeat step 1
3. repeat step 2

You clicked install now on the web page. Then the xpinstall dialog is displayed (see attached screenshot). 

With the screenshot as a reference...
At what point in the steps did the xpinstall dialog (the dialog with the
countdown for confirming the install) display in the steps to reproduce? Was it
displayed more than once? Did you confirm the install (e.g. press Install Now in the xpinstall dialog) more than once?

Also, if you have talkback installed (can be found in the installed extensions list) could you enable it and provide a talkback incident ID?
http://www.mozilla.org/quality/qfa.html

This is most likely a duplicate of bug 259688
(Reporter)

Comment 4

11 years ago
Oh the xpidialog is displayed.... after step 3 I guess... I confirmed the install. I only confirmed once. The dialog appeared more then once. If you think it is a duplicate then close it or whatever you do.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 259688
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.