cannot debug installed xulrunner - make install ignores '--disable-strip'

RESOLVED FIXED

Status

()

Core
Build Config
--
major
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Sergey Yanovich, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070723 Iceweasel/2.0.0.6 (Debian-2.0.0.6-1)
Build Identifier: 20070807

Although '--disable-strip' is passed to ./configure, all binaries in $(pkglibdir)  are installed without debugging symbols. This makes debugging impossible.

Reproducible: Always

Steps to Reproduce:
1. ./configure ... --disable-strip ...
2. make
3. make install
Actual Results:  
sizeof libxul.so is 15Mb

Expected Results:  
sizeof libxul is ~140Mb

Stripping seems to occur in 'stage-package' make target.

Comment 1

10 years ago
--disable-strip is the default, and it strips "immediately" as we build the objects in rules.mk

We probably need a separate --disable-install-strip or something to indicate that the installed files shouldn't be stripped.

As a workaround, you can set PKG_SKIP_STRIP to avoid stripping the packaged bits.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

10 years ago
May be it makes sense to set PKG_SKIP_STRIP to (! ENABLE_STRIP) by default, and then separately configure the former with '--enable-install-strip'?

I can make this kind of patch to 'configure.in'.

Comment 3

10 years ago
Given the way mozilla typically does releases, this does not make sense:

We do release builds without --enable-strip: then we separate out the debug symbols for the crash-reporting application and package up the bits for release (stripping them in the process). Changing this default behavior now is not really practical. However, adding an --disable-install-strip flag is perfectly reasonable. If you can do it, I'm happy to review, or I can probably get to it at some point, maybe next week.
(Reporter)

Comment 4

10 years ago
Created attachment 275819 [details] [diff] [review]
patch adds '--enable-install-strip' ./configure option

If '--disable-install-strip' option is supplied, PKG_SKIP_STRIP=1 is set.

Comment 5

10 years ago
Comment on attachment 275819 [details] [diff] [review]
patch adds '--enable-install-strip' ./configure option

You need an AC_SUBST(PKG_SKIP_STRIP) or the variable will never be substituted ;-)
Attachment #275819 - Flags: review-
(Reporter)

Comment 6

10 years ago
Created attachment 275821 [details] [diff] [review]
patch adds '--enable-install-strip' ./configure option v2

I have already gone home, but remembered AC_SUBST :) So I am back. Its 23:44 in Moscow.
Attachment #275819 - Attachment is obsolete: true

Comment 7

10 years ago
r=me and fixed on trunk
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Duplicate of this bug: 392659
You need to log in before you can comment on or make changes to this bug.