Does not work behind a proxy with authentication

RESOLVED FIXED in 0.8

Status

Calendar
Provider: GData
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: patrice Arnal, Assigned: Fallen)

Tracking

Lightning 0.5

Details

(Whiteboard: [gdata-0.4])

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Lightning 0.5 Build 2007062404 + Provider for Google Calendar 0.2.1

On the same laptop, when I am at home ( direct internet connection), I can get all my Google calendars event in Lightning / Sunbird; 
at work, I am behind a proxy requesting an authentication.
I can't get my google calendars, and I did not receive the authentication pop-up.

I get them corectly in Lightning from http://icalx.com/private/patricearnal/professionnel2.ics, for instance


Reproducible: Always

Steps to Reproduce:
1.start Firefox at work
2.answer the authentication pop up from proxy
3.open the calendar view
Actual Results:  
Get only the ICAL provider events, not the google ones

Expected Results:  
get all calendars events

Works fine from home : no proxy

Comment 1

11 years ago
Have you configured the correct HTTP and SSL proxy in Thunderbird? 
Do you see any error messages in the Error Console?
Version: unspecified → Lightning 0.5
(Assignee)

Updated

11 years ago
Duplicate of this bug: 401570

Comment 3

10 years ago
I'm using in thunderbird, my proxy settings are ok and the error in my console is this:

Erro: [Exception... "'Component does not have requested interface' when calling method: [nsIInterfaceRequestor::getInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "<unknown>"  data: no]

I still can't get the proxy (squid) configuration, sorry.
Thanks all.
(Assignee)

Comment 4

10 years ago
Created attachment 302833 [details] [diff] [review]
Fix proxy authentication

I should have done this much earlier, it was so easy to fix :) Sorry for the delay!

Tested with a apache basic auth proxy
Assignee: nobody → philipp
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #302833 - Flags: review+
(Assignee)

Comment 5

10 years ago
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Whiteboard: [gdata-cvs]
Target Milestone: --- → 0.8
(Assignee)

Updated

10 years ago
Whiteboard: [gdata-cvs] → [gdata-0.4]
You need to log in before you can comment on or make changes to this bug.