Closed Bug 391409 Opened 15 years ago Closed 15 years ago

Cleaning up all OS widget makefiles

Categories

(Core :: Widget, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9beta1

People

(Reporter: xfsunoles, Assigned: xfsunoles)

Details

Attachments

(1 file, 9 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007080805 Firefox/3.0a7pre
Build Identifier: 

Cleaning up all OS makefiles that will remove MOZ_ENABLE_CAIRO_GFX checks. Also, I found there is gfxwin that is under requires in the windows makefiles. Maybe, there is still requires old gfx folder in another makefiles. 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Attached patch windows makefiles (obsolete) — Splinter Review
removed gfxwin and MOZ_ENABLE_CAIRO_GFX checks.
Attachment #276081 - Flags: review?(roc)
Comment on attachment 276081 [details] [diff] [review]
windows makefiles

>Index: Makefile.in
>===================================================================
>RCS file: /cvsroot/mozilla/widget/src/windows/Makefile.in,v
>retrieving revision 3.48
>diff -u -8 -p -r3.48 Makefile.in
>--- Makefile.in	25 Jan 2007 21:13:32 -0000	3.48
>+++ Makefile.in	8 Aug 2007 18:48:11 -0000
>@@ -48,38 +48,35 @@ LIBXUL_LIBRARY = 1
> 
> REQUIRES	= xpcom \
> 			string \
> 			dom \
> 			accessibility \
> 			content \
> 			content_xul \
> 			gfx \
>-			gfxwin \
> 			necko \
> 			pref \
> 			plugin \
> 			timer \
> 			uconv \
> 			intl \
> 			locale \
> 			webshell \
> 			docshell \
> 			layout \
> 			xuldoc \
> 			view \
> 			imglib2 \
> 			uriloader \
> 			webbrowserpersist \
> 			unicharutil \
>+			thebes \
>+                      cairo  \
> 			$(NULL)
> 
>-ifdef MOZ_ENABLE_CAIRO_GFX
>-REQUIRES += thebes cairo
>-endif
> 
> CPPSRCS		= \
> 	L_Ienumfe.cpp  \
> 	nsWindow.cpp         \
> 	nsAppShell.cpp       \
> 	nsLookAndFeel.cpp    \
> 	nsToolkit.cpp        \
> 	nsKeyboardLayout.cpp \
+			thebes \
+     cairo  \

Put tabs before "cairo".
Attached patch Patch v1.1 (obsolete) — Splinter Review
Attachment #276081 - Attachment is obsolete: true
Attachment #276081 - Flags: review?(roc)
Attachment #276872 - Attachment is obsolete: true
Attached patch Patch v1.2 (obsolete) — Splinter Review
Attachment #276873 - Attachment is obsolete: true
Attached patch Patch v1.3 (obsolete) — Splinter Review
Attachment #276878 - Flags: superreview?(roc)
Attachment #276878 - Flags: review?(roc)
Attachment #276878 - Flags: superreview?(roc)
Attachment #276878 - Flags: superreview+
Attachment #276878 - Flags: review?(roc)
Attachment #276878 - Flags: review+
Attachment #276878 - Flags: approval1.9?
Attached patch Remove CAIRO_Checks from OS2 (obsolete) — Splinter Review
Assignee: nobody → xfsunoles
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #276878 - Attachment is obsolete: true
Attachment #276878 - Flags: approval1.9?
Attachment #277261 - Attachment is obsolete: true
Attachment #277262 - Attachment is obsolete: true
Attachment #279509 - Flags: superreview?(roc)
Attachment #279509 - Flags: review?(roc)
Can you fix the lines with "no newline at end of file"?
Jonathan, are you sure you want to do these removals one type of file at a time? We have non-cairo removal bugs for the whole of widget for the platforms already, just waiting to get in. (E.g. bug 389729 for OS/2.)
(In reply to comment #11)
> Jonathan, are you sure you want to do these removals one type of file at a
> time? We have non-cairo removal bugs for the whole of widget for the platforms
> already, just waiting to get in. (E.g. bug 389729 for OS/2.)
> 

Yes, I don't want too much patch in same bugs since it can be confusing which one to get check-in or not.
Attached patch r (obsolete) — Splinter Review
Attachment #279509 - Attachment is obsolete: true
Attachment #279865 - Flags: superreview?(roc)
Attachment #279865 - Flags: review?(roc)
Attachment #279509 - Flags: superreview?(roc)
Attachment #279509 - Flags: review?(roc)
Attachment #279864 - Attachment is obsolete: true
Attachment #279865 - Attachment is obsolete: true
Attachment #279865 - Flags: superreview?(roc)
Attachment #279865 - Flags: review?(roc)
Attachment #279866 - Flags: superreview?(roc)
Attachment #279866 - Flags: review?(roc)
Attachment #279866 - Flags: superreview?(roc)
Attachment #279866 - Flags: superreview+
Attachment #279866 - Flags: review?(roc)
Attachment #279866 - Flags: review+
Attachment #279866 - Flags: approval1.9+
Status: NEW → ASSIGNED
Keywords: checkin-needed
Comment on attachment 279866 [details]
279865: Remove GFX from widget directory in makefiles v3

>Index: os2/Makefile.in

Bug 389729 already took care of the os2 parts.
Checked-in without os2 changes:

Checking in widget/src/beos/Makefile.in;
/cvsroot/mozilla/widget/src/beos/Makefile.in,v  <--  Makefile.in
new revision: 1.56; previous revision: 1.55
done
Checking in widget/src/build/Makefile.in;
/cvsroot/mozilla/widget/src/build/Makefile.in,v  <--  Makefile.in
new revision: 1.72; previous revision: 1.71
done
Checking in widget/src/windows/Makefile.in;
/cvsroot/mozilla/widget/src/windows/Makefile.in,v  <--  Makefile.in
new revision: 3.49; previous revision: 3.48
done
Checking in widget/src/xpwidgets/Makefile.in;
/cvsroot/mozilla/widget/src/xpwidgets/Makefile.in,v  <--  Makefile.in
new revision: 1.82; previous revision: 1.81
done
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M9
You need to log in before you can comment on or make changes to this bug.