window raise (focus stealing) when quick findbar closes

RESOLVED DUPLICATE of bug 332990

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 332990
11 years ago
10 years ago

People

(Reporter: logan, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
When the quick findbar closes, Firefox raises the window and subsequently steals focus away from other windows (Fluxbox).

Commenting:

http://lxr.mozilla.org/mozilla/source/toolkit/content/widgets/findbar.xml#721

743                   else
744                     this.browser.contentWindow.focus();

takes care of the raise problem, but then the page can no longer be scrolled with the keyboard as the document isn't refocused. The same call runs if the first try {} fails and of course there's other cases in the if () which focus and may raise (didn't test).

This didn't happen in 2.0 and earlier.

Comment 1

11 years ago
I would say this is a dupe of bug 332990, but that bug has been around since before Firefox 2.
(Reporter)

Comment 2

11 years ago
Hmph, I can't reproduce that. I've been Openbox3 and Fluxbox for the last few years, don't remember seeing it in either...
(Reporter)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 332990
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.