Bug 391487 (whack-a-mole)

Link to bug in attachment details page moves (doesn't open) when you click it

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: nelson, Unassigned)

Tracking

x86
Windows XP

Details

This is seen in Bugzilla 3.0 on b.m.o and on landfill.
Please adjust the component if I've chosen the wrong one.

When you're on the attachment details page for any patch,
at the top of the page is a black bar containing white text.
In that bar is an underlined link to the bug page itself.
When you click on that link, the link MOVES to a different 
place in the page, like a game of whack-a-mole.  It moves to
the beginning of a new line in the black bar, beneath the 
line it was on when you clicked it.  It gets old real quick.

Steps to reproduce:
Go to the attachment details for any patch to any bug.  
For example, you could go to 
https://landfill.bugzilla.org/bugzilla-3.0-branch/attachment.cgi?id=222&action=edit
or to 
https://bugzilla.mozilla.org/attachment.cgi?id=273069&action=edit

Move your mouse over the link to the bug report in the black bar along top.
(e.g. that says Bug 356855 or Bug 1151 in the examples above).  
Click it.

Expected result:  browser fetches page with bug report
Actual results:   the link and its text moves.  no page fetch occurs.

A new line is created in the black bar (which gets taller to accommodate
the new line), and the text moves to the beginning of the new line.
You get to chase it with your mouse and whack it there.   :-/
(Reporter)

Updated

12 years ago
Alias: whack-a-mole
Um, wow. I've never seen this happen. What browser are you using, on what OS? Do you have some crazy Firefox extension installed that might be causing this?

Comment 2

12 years ago
WFM. This behavior was visible in Bugzilla 2.22 but has been fixed in 3.0. I'm surprised you still see it.
I run nightly browser builds from the trunk.  I've been seeing this for 
months, and it just got to the point where I had to file a bug on it.

Comment 4

12 years ago
i hit this fairly often

Comment 5

12 years ago
(In reply to comment #3)
> I run nightly browser builds from the trunk.

Could it be a bug in Fx3?
If it is a browser bug, then it is a gecko bug, because it is also seen in 
SeaMonkey trunk builds.
Months have elapsed since I filed this bug.
I have upgraded to a newer trunk nightly browser several times, and
various changes to BMO software have been made, and now I no longer
experience whack-a-mole.  So -> WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Target Milestone: Bugzilla 3.0 → ---
You need to log in before you can comment on or make changes to this bug.