bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Allow association of keyboard shortcuts with arbitrary bookmarks, and unset Cmd-1 through Cmd-9

RESOLVED WONTFIX

Status

Camino Graveyard
Toolbars & Menus
RESOLVED WONTFIX
11 years ago
4 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Unassigned)

Tracking

Details

Spun off from bug 365270:

Comment #12  [reply]  Stuart Morgan   2007-03-22 17:14:22 PDT

(In reply to comment #11)
[...]
But then, my opinion is that the right behavior is to rip this out entirely. I
think it's terrible UI, and that if we want to make it easy to load certain
bookmarks with keyboard shortcuts we should make it possible to associate
shortcuts with arbitrary bookmarks (or just tell people to use the keyboard
pref pane).

Comment #13 [reply] froodian (Ian Leue)  2007-03-22 22:24:25 PDT

(In reply to comment #12)
> if we want to make it easy to load certain
> bookmarks with keyboard shortcuts we should make it possible to associate
> shortcuts with arbitrary bookmarks (or just tell people to use the keyboard
> pref pane).
> 

I personally think this is the real solution here.  It eliminates the annoying
case of triggering bookmarks accidentally, removes confusion for those who
aren't "in the know" (read:almost everyone), and is more powerful.  Users who
like the current behavior could still get it by applying the shortcuts 1-9 to
the first 9 bookmarks in the bookmarks bar, so nobody loses.

Comment #14 [reply] Smokey Ardisson (offline 29 Jul - 7 Aug; no bugmail - do not email)  2007-04-11 22:51:45 PDT

The only drawback to that solution (which I otherwise like) is that to do so,
we'd have to add the Bookmark Bar collection to the menu, too :/

Comment #15 [reply] froodian (Ian Leue)  2007-04-12 01:10:39 PDT

(In reply to comment #14)
> The only drawback to that solution (which I otherwise like) is that to do so,
> we'd have to add the Bookmark Bar collection to the menu, too :/

I don't believe that'll be necessary to fix this.

I've been looking at this a little, and I think it could make a great
replacement for our current bookmark shortcuts.  It could appear/be edited
everywhere the current shortcuts are (column in BM, field in bookmark info
panel), it's just that instead of giving a string, you give a shortcut.  We
could still support shortcuts with arguments (if bookmark url contains %s,
popup a sheet with a text field), so they'd be functionally equivalent, just
with a different (faster and better understood) accelerator.

We should decide if this is something we want, since I'm kind of itching to
implement it if it is.
The drawback I just thought of is that we'd "have" to do validation to make sure they don't use assign any shortcut currently in use in Camino.

Comment 2

11 years ago
(In reply to comment #1)
> The drawback I just thought of is that we'd "have" to do validation to make
> sure they don't use assign any shortcut currently in use in Camino.
> 

Ideally that validation would check whether the shortcut is in use *anywhere* in the responder chain, rather than just in Camino.

I'd really like to see this only in addition to the existing bookmark shortcuts though --- keyboard shortcuts are great for the absolute most visited websites, but the current shortcuts are great for less often visited websites, as well as several purposes, such as automatically correcting frequent typos or fixing urls that should automatically redirect/autocomplete but don't.

As for having shortcuts for search engines: I think it would be much better to have shortcuts that change the search bar's search engine than to pop down a dialog.

Comment 3

10 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > The drawback I just thought of is that we'd "have" to do validation to make
> > sure they don't use assign any shortcut currently in use in Camino.
> > 
> 
> Ideally that validation would check whether the shortcut is in use *anywhere*
> in the responder chain, rather than just in Camino.

Based on some digging I've done, I'm not entirely sure that's even possible, although I agree it would be the ideal validation check.

I'm going to confirm this based on Stuart, Smokey, Ian, and myself all being in favour of doing it and no objections that I can recall since it was filed.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

10 years ago
I agree with this plan but think that Cmd-1 through 9 should default to the bookmark bar as it is implemented now.  Removing the shortcuts will confuse users upgrading from previous versions of Camino or switching from Safari.

Side note: if Cmd-1 through 9 does not open a webpage without a Camino window open because that would confuse the user, why does Command-L and Command-Option-F, etc. work?

Comment 5

10 years ago
The shortcuts that always work are basic functionality in the application menu, are discoverable, and provide visual feedback. Command-1 to 9 are completely invisible shortcuts that apply to bookmarks that some users never see, because they don't use the bookmark bar. Those users were very confused when they accidentally pressed a number shortcut (often without realizing they had done so) and a random page they didn't even know they had bookmarked suddenly loaded with absolutely no visual feedback about why.

This is completely irrelevant to this bug though, because once shortcuts are being deliberately chosen by users we will allow them to work everywhere.
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.