Browser immediately crashes on opening this web page

RESOLVED INCOMPLETE

Status

()

Core
General
--
critical
RESOLVED INCOMPLETE
11 years ago
10 years ago

People

(Reporter: Bob Peers, Unassigned)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7) Gecko/2007080209 GranParadiso/3.0a7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7) Gecko/2007080209 GranParadiso/3.0a7

On trying to open this web page the browser crashes without any talkback report or any other crash info. This occurs every time either if opened from a link into a new tab or if pasted into the location bar manually.
This is on a clean profile with no add ons installed.

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.karup-airport.dk/
2.Browser crashes
3.
Actual Results:  
Browser crashes

Expected Results:  
Opened web page normally

This web page works fine on the same computer using firefox 2.0.0.6
Which Java Version Do you use (enter "about:plugins" as URl) and are you sure that the plugin is correctly symlinked ?

Do you also crash if you open : http://www.java.com/en/download/help/testvm.xml
Can you give us a Breakpad ID for this crash as well? http://kb.mozillazine.org/Breakpad
Component: General → General
Keywords: crash, stackwanted
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk
(Reporter)

Comment 3

11 years ago
The Java version is:
Java(TM) Plug-in 1.6.0_02-b05

    File name: libjavaplugin_oji.so
    Java(TM) Plug-in 1.6.0_02

Going to the page http://www.java.com/en/download/help/testvm.xml crashes the browser every time.

This plugin works fine in firefox 2.0.0.6 and also worked in the alpha 6. I have a symlink in both /usr/lib/mozilla/plugins and /home/username/.mozilla/plugins.

Having looked for the breakpad ID from the linked page there are no crash reports in that location.

There is something wrong with your java oinstallation. Either the symlink is somehow broken or the JVM itself is broken because i didn't see a bug from another report with the same problem (and they would be bugs open if java would be broken on linux)
Bob, can you try a clean profile? If this is indeed crashing, we need a stack trace for it, if not a Breakpad ID (which would be better).

http://kb.mozillazine.org/Profile Manager
(Reporter)

Comment 6

11 years ago
I tried a clean profile with the same results. Breakpad also crashed on Fedora 7 with this error:
/usr/lib/firefox3/firefox/crashreporter: error while loading shared libraries: libcurl.so.3: cannot open shared object file: No such file or directory

I have libcurl.so.4 installed not so.3

Comment 7

10 years ago
There are two problems here.  First there was a Firefox crash and then
"crashreporter" failed to launch because libcurl.so.3 is missing on
your system. The second problem is bug 392919.

Bug 389405 comment 6 suggests that creating a symlink fixes crashreporter -
can you try that and then crash Firefox again and submit the crash data?
Then let us know the UUID for the crash.  Thanks.
See  http://kb.mozillazine.org/Breakpad#Location_of_crash_reports
Severity: normal → critical
(Reporter)

Comment 8

10 years ago
This will probably have to be closed since I'm running Fedora 8 now and Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007113004 Minefield/3.0b2pre and the problem no longer exists so I can't provide any more info on the bug, sorry.

Comment 9

10 years ago
Ok, thanks for taking the time to report the problem.

-> INCOMPLETE
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.