find As You Type (FAYT, Quick Find) doesn't work until Next/ctrl-g with incompatible theme applied

RESOLVED INVALID

Status

()

Toolkit
Find Toolbar
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: myk, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
On the trunk, Find As You Type (FAYT, Quick Find) doesn't work until you press the Next button or hit the ctrl-g keyboard shortcut.  In Firefox 2, it started finding what you were looking for the moment you started typing text into the Quick Find textbox.  The Fx2 behavior is preferable, since it makes it faster to find the first match (which is often the text one is looking for).  We should revert to that behavior.
(Reporter)

Updated

10 years ago
Whiteboard: [catfood]
(Reporter)

Updated

10 years ago
Keywords: regression
Whiteboard: [catfood] → [myk:catfood]
When did this regress?
I'm not sure I understand the steps to reproduce, either.

If I enable "Search for text when I start typing" in Options->Advanced->General, go to http://mozilla.org, and type "foundation" without opening the findbar or doing anything else, the "quick find" bar opens with "foundation" in it, and "Foundation" is highlighted on the page. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070808 BonEcho/2.0.0.7pre
(Reporter)

Comment 3

10 years ago
> When did this regress?

I'm not sure.  I think it's been this way for months.


> If I enable "Search for text when I start typing" in
> Options->Advanced->General, go to http://mozilla.org, and type "foundation"
> without opening the findbar or doing anything else, the "quick find" bar opens
> with "foundation" in it, and "Foundation" is highlighted on the page.

Yup, that's not what happens for me.  The "quick find" bar does open, and it does contain the word "foundation", but "Foundation" isn't highlighted on the page.  I have to press the Next button or hit ctrl-g for it to be highlighted.


> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070808
> BonEcho/2.0.0.7pre

This is a Firefox 2 user agent.  Firefox 2 works for me.  It's just trunk that has regressed, for example this Linux nightly from four days ago:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007080604 Minefield/3.0a8pre
(In reply to comment #3)
> > When did this regress?
> 
> I'm not sure.  I think it's been this way for months.
> 
> 
> > If I enable "Search for text when I start typing" in
> > Options->Advanced->General, go to http://mozilla.org, and type "foundation"
> > without opening the findbar or doing anything else, the "quick find" bar opens
> > with "foundation" in it, and "Foundation" is highlighted on the page.
> 
> Yup, that's not what happens for me.  The "quick find" bar does open, and it
> does contain the word "foundation", but "Foundation" isn't highlighted on the
> page.  I have to press the Next button or hit ctrl-g for it to be highlighted.
> 
> 
> > Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070808
> > BonEcho/2.0.0.7pre
> 
> This is a Firefox 2 user agent.

Ugh, sorry. I pasted the wrong user agent string - I was testing both a trunk and branch build to compare, and pasted the branch UA by mistake. I tested this in a trunk build on windows, and just now again on Mac, and I still can't reproduce this bug. The same mistake applies to the other findbar bugs you filed :(.
(Reporter)

Comment 5

10 years ago
Some focused testing reveals that the problem in this bug and in the other two bugs reporting similar problems (bug 391602, bug 391603) is caused by an incompatible theme (Tango 2.0.0) which is the selected theme (general.skins.selectedSkin) being applied as the theme for the application because extension compatibility checking (extensions.checkCompatibility) is turned off.

If I turn extension compatibility checking back on, or if I select a compatible theme like the Firefox default, then the problem goes away.  And if I then turn extension compatibility checking back on and select the incompatible theme again, then the problem returns.

So I'm inclined to say that these bugs are invalid, since they describe a problem in a configuration that we explicitly don't support, because it can result in bugs such as this one.  But if anyone thinks there's a valid bug here, and that users should be able to count on FAYT and the find toolbar working correctly when an incompatible theme is applied, then reopen the bug.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: regression
Resolution: --- → INVALID
Summary: find As You Type (FAYT, Quick Find) doesn't work until Next/ctrl-g → find As You Type (FAYT, Quick Find) doesn't work until Next/ctrl-g with incompatible theme applied
Whiteboard: [myk:catfood]
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.