find toolbar doesn't go to next result on return/enter with incompatible theme applied

RESOLVED INVALID

Status

()

Toolkit
Find Toolbar
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: myk, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
On the trunk, the find toolbar doesn't go to the next matching result when you press the Enter/Return key with the cursor in the textbox.  This makes it more cumbersome to jump from result to result, since you have to either press the Next button or hit the ctrl-g shortcut.

In Firefox 2, the toolbar took you to the next result when you pressed return/enter.  Since return/enter isn't being used for anything else in the toolbar, it seems like it should continue to do what it did in Firefox 2.
(Reporter)

Updated

11 years ago
Whiteboard: [myk:catfood]
I can't reproduce this with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070808 BonEcho/2.0.0.7pre. Pressing "Ctrl+F" on this page, entering "find", and then pressing "Enter" repeatedly cycles through all of the instances of the word "find" on the page. If I use the "quick find" bar instead of "Ctrl+F", Enter does nothing unless a link is focused, but that matches Firefox 2 behavior.
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> I can't reproduce this with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> rv:1.8.1.7pre) Gecko/20070808 BonEcho/2.0.0.7pre.

That's a Firefox 2 user agent.  This is a regression on the trunk, for example this Linux nightly from four days ago:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007080604 Minefield/3.0a8pre
(In reply to comment #2)
> (In reply to comment #1)
> > I can't reproduce this with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> > rv:1.8.1.7pre) Gecko/20070808 BonEcho/2.0.0.7pre.
> 
> That's a Firefox 2 user agent.

Sorry, I pasted the wrong user agent string. I was testing a *trunk* windows build but posted the branch UA string by mistake. I additionally just tested a Mac trunk build and still can't reproduce this bug.
(Reporter)

Comment 4

11 years ago
Invalid per bug 391601 comment 5.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: regression
Resolution: --- → INVALID
Summary: find toolbar doesn't go to next result on return/enter → find toolbar doesn't go to next result on return/enter with incompatible theme applied
Whiteboard: [myk:catfood]
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.