All users were logged out of Bugzilla on October 13th, 2018

win32 build fails to start up

VERIFIED FIXED in M16

Status

P3
blocker
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: sspitzer, Assigned: asa)

Tracking

({platform-parity, regression})

Trunk
x86
Windows NT
platform-parity, regression

Firefox Tracking Flags

(Not tracked)

Details

I hope this is just a fluke.

linux starts up fine.

here's where it is hung.

tried -nosplash, to see if that would help, but no luck.

USER32! 77eb08f5()
USER32! 77e73122()
USER32! 77ea10ae()
USER32! 77e87251()
USER32! 77ea0857()
nsNativeAppSupportWin::Start(nsNativeAppSupportWin * const 0x00c449e0, int * 
0x0012ff50) line 565 + 27 bytes
main(int 1, char * * 0x00c44a20) line 1013 + 16 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77f1ba06()

Comment 1

19 years ago
2000051220 seemed to load fine for me on win98
how about the 2000051308 build?

Comment 3

19 years ago
will try on that when it becomes available

Comment 4

19 years ago
You're right - I can't start 2000051308 on win98.  Get a GPF in XPCOM.dll, 
cc'ing dp.  Talkback incident ID: TB10440393W

Raising severity
Severity: normal → blocker
Keywords: crash, regression
Summary: win32 build fails to start up → win32 build fails to start up - crashes
the 5-13-9am build from ftp://ftp.mozilla.org (mozilla-win32.zip) doesn't crash 
for me.  hmm.  maybe I'm crying wolf here?  let me wait until my build is done.

Comment 6

19 years ago
I made a mistake in my last comment: I wasn't on win98 when it didn't work, I 
was on Windows ME (Millennium) RC0.  (I've upgraded from 98 so I can't test and 
see if 51308 also crashes under that for me). 

I sure hope the problem isn't just that Mozilla doesn't work under Millennium, 
period, cause then I gotta revert back to win98.  Furthermore, apparently ME 
(or this release candidate, anyways) no longer spews back anything in 
GPF's...the Details button is totally gone.   Can someone get the talkback data 
please (I posted the incident ID earlier)?

Seth, lemme know how your build goes.  You wouldn't happen to have a copy of ME 
RC0 lying around to get me a stack trace, would you?  Perhaps you could try it 
in one of the nscp labs?

Comment 7

19 years ago
I can run 2000-05-13-08 without problem on win2k. Will try win95 in a moment.

Comment 8

19 years ago
Here's the stack trace from the talkback incident.

PL_strcmp() 
nsStdURL::GetFileName 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStdURL.cpp, line 980] 
NKFILE.DLL + 0x1534 (0x60691534) 
NKFILE.DLL + 0x22ee (0x606922ee) 
nsIOService::QueryInterface 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsIOService.cpp, line 106] 
NS_OpenURI [..\..\..\dist\include\nsNetUtil.h, line 188] 
NS_OpenURI [..\..\..\dist\include\nsNetUtil.h, line 124] 
RDFXMLDataSourceImpl::Refresh 
[d:\builds\seamonkey\mozilla\rdf\base\src\nsRDFXMLDataSource.cpp, line 911] 
nsChromeRegistry::LoadDataSource 
[d:\builds\seamonkey\mozilla\rdf\chrome\src\nsChromeRegistry.cpp, line 612] 
nsChromeRegistry::AddToCompositeDataSource 
[d:\builds\seamonkey\mozilla\rdf\chrome\src\nsChromeRegistry.cpp, line
1604] 
nsChromeRegistry::ConvertChromeURL 
[d:\builds\seamonkey\mozilla\rdf\chrome\src\nsChromeRegistry.cpp, line 390] 
nsChromeProtocolHandler::NewChannel 
[d:\builds\seamonkey\mozilla\rdf\chrome\src\nsChromeProtocolHandler.cpp, line
688] 
nsIOService::QueryInterface 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsIOService.cpp, line 106] 
NS_OpenURI [..\..\dist\include\nsNetUtil.h, line 104] 
nsDocShell::DoURILoad [d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, 
line 2531] 
nsDocShell::InternalLoad 
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 2297] 
nsDocShell::LoadURI [d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, 
line 215] 
GlobalWindowImpl::OpenInternal 
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 2644] 
GlobalWindowImpl::OpenDialog 
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 1630] 
NS_NewURI [..\..\dist\include\nsNetUtil.h, line 52] 
Ensure1Window [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 
589] 
LaunchApplication [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, 
line 324] 
nsPref::EnumerateChildren 
[d:\builds\seamonkey\mozilla\modules\libpref\src\nsPref.cpp, line 1000] 
LaunchApplicationWithArgs 
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 340] 
HandleArbitraryStartup 
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 510] 
DoCommandLines [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 
547] 
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1021] 
NS_SetupRegistry 
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\../../webshell/tests/viewer/nsSetupR
egistry.cpp, line 325] 
MOZILLA.EXE + 0x397a (0x0040397a) 
KERNEL32.DLL + 0x1b9e4 (0xbff7b9e4) 
KERNEL32.DLL + 0x1b896 (0xbff7b896) 
KERNEL32.DLL + 0x1a24f (0xbff7a24f) 

Comment 9

19 years ago
Thanks, John.

Any ideas from the stack, anyone?

Comment 10

19 years ago
Lowering severity to critical; I now fear this might just be a problem with 
Windows Millennium, and since that's only a RC, we can't be expected to support 
it.  I don't want to hold the tree/anything up with this blocker.
Severity: blocker → critical
marking invalid, my last build works fine.  false alarm.  I'll put down the
crack pipe now.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 12

19 years ago
Any ideas about my situation (see the stack trace)?
Status: RESOLVED → VERIFIED

Comment 13

19 years ago
Blake -- can you try a clean install (just to be certain) -- delete 
mozregistry.dat, your .\users50 directory, and install to a clean/empty
directory (or move these items to c:\foobar to get them out of the way).
If you still get the crash, then file a new bug. Thanks.

Comment 14

19 years ago
  This will happen to a lot of people, but only once. I sent a note to the 
mozilla newsgroup and to seamonkey-internal about this, but doubtless a lot of 
people will miss the message. They'll all have problems. I wasn't expecting a 
crash...
  The problem is, there's obsolete information in your dist/bin/chrome directory 
that confuses things. The bad things should be cleared out after you run once, 
but you really want to delete dist before building after pulling today.
  By the way, the Netscape commercial build is quite broken on Windows and Unix 
after this checkin. I'm resurrecting that right now.

Comment 15

19 years ago
On Windows Millennium RC0, I cannot start 051316.  (John, I'm not gonna open a 
new bug since this seems to be the same problem as initially reported it - it's 
no longer crashing for me, just hanging as seth reported).

This appears in the console upon starting (while it's just hanging at the 
splash screen):

stdout directed to dynamic console
stderr directed to dynamic console
Profile Manager : Profile Wizard and Manager activites : Begin
Profile Manager : Command Line Options : Begin
Profile Manager : Command Line Options : End
ProfileManager : GetProfileDir
ProfileManager : GetProfileDir
Profile Manager : Profile Wizard and Manager activites : End
has multiple monitor apis is 1
WEBSHELL+ = 1
WEBSHELL+ = 2
Java HotSpot(TM) Client VM warning: Setting of property "java.compiler" is ignor
ed
initialization error: Can't load class netscape/javascript/JSUtil


This is after wiping everything out and using the mozilla-win32-installer.exe 
build to do a completely fresh install into a new directory.

Status: VERIFIED → REOPENED
Keywords: crash
Resolution: INVALID → ---
Summary: win32 build fails to start up - crashes → win32 build fails to start up

Comment 16

19 years ago
As danm noted above, he's been whacking the chrome directory pretty 
hard. It looks possible that this has affected the verification build
for win32 -- I can run viewer from the -talkback.zip but not mozilla;
my linux clobber build just finished and runs fine.

I expect that for tomorrow's a.m. builds, everything should be fine,
but this particular ftp.mozilla.org build is hosed (oh, well). 

(reducing the cc: list)
Severity: critical → normal
QA Contact: jelwell → jrgm

Comment 17

19 years ago
*** Bug 39169 has been marked as a duplicate of this bug. ***

Comment 18

19 years ago
Raising severity back to blocker.

I've heard from multiple people that the 051409 builds aren't starting on 
win98.  

Mine still isn't getting past the splash screen, console reads:

stdout directed to dynamic console
stderr directed to dynamic console
Profile Manager : Profile Wizard and Manager activites : Begin
Profile Manager : Command Line Options : Begin
Profile Manager : Command Line Options : End
ProfileManager : GetProfileDir
ProfileManager : GetProfileDir
Profile Manager : Profile Wizard and Manager activites : End
has multiple monitor apis is 1
WEBSHELL+ = 1
 I am inside the initialize
 Hey : You are in QFA Startup
(QFA)Talkback loaded Ok.
WEBSHELL+ = 2
Severity: normal → blocker
Keywords: pp

Comment 19

19 years ago
I dunno if that's for all builds, it seems to be true for any "pre-compilied"
nightlies from mozilla.org since 2000-05-13-16. And for all platforms. The
builds hang while splash screen is showing.
And it's not only happening once and running fine at the second try to start.
It's hanging at every start of mozilla. (used 2000-05-14-09, win98)
there was a big chrome re-org this weekend.

could this be a packaging problem?  my builds are working ok.

dan, did the packager-* files (ns and mozilla tree) get updated?

Comment 21

19 years ago
  This is a different problem from this report's original. We've rearranged the 
chrome into a hierarchy in which the application can't find files without hints 
from the installer. The build system fakes some hints, but the installer folks 
haven't had a chance to catch up. So builds will work fine, but pre-packaged 
installer builds will choke on their own chrome.
  Relenting from our rudeness, we've since patched the default chrome location 
code so it won't require installer hints. The pressure's off the installer guys. 
Tonight's nightly builds should be fixed.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
Target Milestone: --- → M16

Comment 22

19 years ago
*** Bug 39249 has been marked as a duplicate of this bug. ***

Comment 23

19 years ago
*** Bug 39272 has been marked as a duplicate of this bug. ***

Comment 24

19 years ago
vrfy fixed (60609 win98/2k)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.