Tree column splitters are really difficult to use

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: neil, Assigned: neil)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
Since the units changes, it can be quite difficult to hover at just the right place to trigger a tree column splitter. Depending on your DPI you used to have about eight pixels to aim at but since the units changes you may only have one.
(Assignee)

Comment 1

11 years ago
Created attachment 276201 [details] [diff] [review]
Proposed patch

Note: By comparison with my branch build, the hit test area appears to be 4 pixels from the right and the left edge and the next 3 pixels. I've thus changed the right check to be <= to allow it to include the 4th pixel.
Assignee: Jan.Varga → neil
Status: NEW → ASSIGNED
Attachment #276201 - Flags: superreview?(roc)
Attachment #276201 - Flags: review?(sharparrow1)

Comment 2

11 years ago
Comment on attachment 276201 [details] [diff] [review]
Proposed patch

r=me assuming that 4px feels like approximately the right amount.
Attachment #276201 - Flags: review?(sharparrow1) → review+
Attachment #276201 - Flags: superreview?(roc) → superreview+
(Assignee)

Comment 3

11 years ago
Comment on attachment 276201 [details] [diff] [review]
Proposed patch

Fix for a noticeable regression that can make tree splitters almost impossible to use.
Attachment #276201 - Flags: approval1.9?
Comment on attachment 276201 [details] [diff] [review]
Proposed patch

a1.9=dbaron
Attachment #276201 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 5

11 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Duplicate of this bug: 389012

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: xptoolkit.trees → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.