Closed Bug 391778 Opened 12 years ago Closed 12 years ago

Selecting product in Sony "support" window opens feedback form in same (tiny) window instead of opening a new window

Categories

(Firefox :: General, defect)

x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 377551

People

(Reporter: StephenFoss, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Had no control over small pop-up window 

Reproducible: Always

Steps to Reproduce:
1.  hop onto:  http://b2b.sony.com/Solutions/product/VGN-N330N/B#
2.  at top of page, click "support"
3.  a firefox window should appear in the upper left corner.  I have no control over maximizing (get no response) this little window thus making it VERY difficult to enter info into a support request!
Actual Results:  
To enter my info I had to continually move the hor. and vert. scroll bars!  Horrible!

Expected Results:  
Should have been able to click on the small, square maximize-window command button (upper right-hand corner) to get the full windows to work on.

Same as above:  Should have been able to click on the small, square maximize-window command button (upper right-hand corner) to get the full windows to work on.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a8pre) Gecko/2007081000 Minefield/3.0a8pre

Clicking "Support" does open a second, tiny window, but when I select a product (e.g. "VAIO Notebooks") from the list, I get a third, normal-sized window.  I assume the support request gets entered in the third window rather than the second window.  Is something different happening for you?

There are bugs asking for all popups to be resizable (bug 101509 for a pref, bug 177838 for the default) but I'm worried there's something else going wrong with the Sony site.  Surely they don't intend for you to have to resize a window that they asked the browser not to let you resize?
Jesse,
You missed my point.  In the "second, tiny window," as you say, and as I said, the point is, it's difficult to transverse in such a tiny window--this tiny window should be able to be maximized but there's no control over it.
Then you said you were able to "select a product from the list" but it's tough to get to that product in the first place.
Can you make that tiny window respond to control (maximization)?
Thank you.  Stephen
Oh, maybe you have larger text size or form controls than me.  On a Mac (MBP) with normalish settings, the two paragraphs and the dropdown fit in the window.  Want to attach a screenshot?

The site has explicitly asked for the window to not be resizable, so "fixing" this on the browser side means fixing bug 177838.  You might also consider contacting Sony and telling them about the issue; they can remove "resizable=no" from their site more quickly than we can remove "resizable=no" support from the browser.
Thanks.
I'm using a PC, AAMOF, I tried this on 2 PC's.  Still get a tiny, untenable window, and no matter what I do I can't get a third window to pop-up--rather, I have to use the vert/hor scroll bars to suffer thru all the text input boxes.
Yes, I will give Sony an earful!
Might as well close this as I doubt Sony will even respond never mind fix the problem!  Thanks again for your diligent attention.  Thank Goodness for Firefox! Stephen
Bug 177838 covers not being able to resize the window, so I'm morphing this bug slightly to cover the initial problem that's causing you want want to be able to resize the window:

"Selecting product in Sony 'support' window opens feedback form in same (tiny) window instead of opening a new window"
Summary: Had no control over small pop-up window → Selecting product in Sony "support" window opens feedback form in same (tiny) window instead of opening a new window
I can't reproduce on Mac with Firefox 2.0.0.5, and Peter6 can't reproduce on Windows.  Are you using any tab-related Firefox extensions or weird tab/window settings?  (Especially weird "force new windows into tabs" settings.)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081314 Minefield/3.0a8pre ID:2007081314

I can't resize the popup
Actually, I think I *can* reproduce (even on trunk), if I first go to Options > Tabs and select "New pages should be opened in: a new tab".  The second window is trying to open a third window without a size, so it's diverted into a tab, despite being in a popup window where opening a new tab doesn't make sense.  Hmm, I bet this is a dup.

(Thanks to fantasai for helping me figure this out.)

Just to make sure, do you see a new tab open in the tiny window when you select the product?
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 377551
> Are you using any tab-related Firefox extensions or weird tab/window
> settings?  (Especially weird "force new windows into tabs" settings.)

It turns out that "New pages should be opened in: a new tab", which has this bad behavior is the default.  Sorry for half-blaming you with talk of "weird settings".  I'm going to push to get bug 377551 fixed in Firefox 3.

Thanks -- this bug report ended up being useful, even though it took a bit of back-and-forth before we understood each other :)
You need to log in before you can comment on or make changes to this bug.