If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Toolbar setting resets itself

RESOLVED DUPLICATE of bug 319196

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 319196
10 years ago
10 years ago

People

(Reporter: Yu Ching Ho, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Every once in a while when I open up Firefox all my tool bars are reset (size, location, etc). This happens usually twice to three times a week

Reproducible: Sometimes

Steps to Reproduce:
1.Close Firefox
2.Open Firefox
3.
Actual Results:  
All tool bars, enabled or not, will be loaded to the default location with all settings gone. Example would be the Google bar, it'll prompt for settings again. I had bookmark bar unchecked but it'll come back up. Always show tabs will be unchecked. Icons will not be small.

Expected Results:  
Nothing. Whatever settings I have should have stayed. The settings shouldn't go away just by restarting Firefox.

Nothing special. Using default theme. Firefox didn't crash so no ID. Computer is of normal components although quite old. P4 2.4GHz, 1GB RAM, WinXP Pro.

There's not exactly a workaround for this. Everytime it happens I'd have to redo all the settings.
See http://kb.mozillazine.org/Toolbar_customizations_reset_on_startup
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 319196
(Reporter)

Comment 2

10 years ago
Thx for the link to the other Toolbar bugs. I've already tried the localstore.rdf methods, but after using Firefox (currently using 2.0.0.6) a few times, the same problem starts happening again.

My problem is not limited to the toolbar either. My preferences will be back to default as well.

My bookmarks are ok thus far. I only lost them once but that's back during the 1.5 upgrade.

Do you know any other settings this can be related to with other possible fixes?

Thanks.
See http://kb.mozillazine.org/Preferences_not_saved
If removing localstore.rdf doesn't help permanently, try disabling extensions.
You need to log in before you can comment on or make changes to this bug.