Cannot Create Calendars with Lightning 0.5 using Ubuntu 7.10 (Gutsy Gibbon)

RESOLVED DUPLICATE of bug 408367

Status

--
critical
RESOLVED DUPLICATE of bug 408367
11 years ago
11 years ago

People

(Reporter: ubuntu.ross.peoples, Unassigned)

Tracking

Lightning 0.5
x86
Linux

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070731 Ubuntu/7.10 (gutsy) Firefox/2.0.0.6
Build Identifier: Thunderbird version 2.0.0.6 (20070802), Lightning version 0.5

After installing Lightning, the only to add new entries is to create a calendar. Creating a new calendar brings up a dialog box asking if you want a local calendar or a remote calendar. Clicking local, then next brings up the next page asking for a name and a color for the calendar. After setting a name and color, clicking the Next button does nothing. I have tried different variations of names and colors with no success. The only two options that work at this point are the Cancel and Back buttons, however, the Next button is enabled (not grayed out).

After canceling/closing this window, clicking on any email crashes Thunderbird. The only way to read your mail again is to uninstall Lightning

Reproducible: Always

Steps to Reproduce:
1. Install Lightning
2. Click Calendars tab
3. Click New..
4. Select local calendar, then click Next
5. Enter a name and color for the calendar, then click Next
Actual Results:  
Nothing happens and the only options left are Back and Cancel.

Expected Results:  
It should have created a new calendar on my computer.

No other addins were installed besides Lightning and the Thunderbird installation is new (just installed, not upgraded) with two Gmail accounts.
Component: Mail Window Front End → Lightning Only
Product: Thunderbird → Calendar
QA Contact: front-end → lightning

Comment 1

11 years ago
Do you see any errors in the Error Console? Do you have write access to your profile folder, normally under ~/.thunderbird ?
You most probably using a Thunderbird build that is incompatible with Lightning on binary level, e.g. by using a different compiler or build environment. Lightning was build to match the Mozilla Thunderbird builds. 

Do you use a Thunderbird from mozilla.org? Or do you use a third party Thunderbird build e.g. the one provided by Ubuntu? In the latter case you either need to build Lightning yourself to match your Thunderbird build or download a Thunderbird build from mozilla.org.
I just checked the official vs. builds provided by Ubuntu 7.10 (gutsy):

mozilla.org: Thunderbird 2.0.0.6 (2007072816) was build using gcc version 3.3.3

Ubuntu 7.10: Thunderbird 2.0.0.6 (2007080214) was build using gcc version 4.1.3 20070718 (prerelease) (Ubuntu 4.1.2-14ubuntu1)

-> This explains why Lightning 0.5 release build won't work, see Comment #2.
Seems there already is a Lightning package provided by Ubuntu 7.10 (gutsy).

Ross, please do the following: 
- Uninstall the Lightning extension from Thunderbird. Restart. Close Thunderbird.
- Select Ubuntu menu Application -> Add/Remove...
- Install "Lightning extension for Thunderbird/Icedove"
(Reporter)

Comment 5

11 years ago
That's what it was. I installed Lightning from apt and all is working well. I must say that it is a wonderful extension now that it's working. So would you recommend installing extensions only from apt, or only from apt while Gusty is in pre-release status?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 6

11 years ago
Lightning differs from many other extension in that it contains binary portions. These portions will only work in the host application on Linux, if the same toolchain (compiler, linker, etc.) is used.

You should therefore be able to use most extensions from addons.mozilla.org

Marking WFM, since we only mark bugs as FIXED if a corresponding code checkin exists.
Resolution: FIXED → WORKSFORME
Summary: Cannot Create Calendars with Lightning → Cannot Create Calendars with Lightning 0.5 using Ubuntu 7.10 (Gutsy Gibbon)
Version: unspecified → Lightning 0.5

Updated

11 years ago
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 408367
You need to log in before you can comment on or make changes to this bug.